summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-09-15 21:52:30 +0200
committerDavid Seifert <soap@gentoo.org>2020-09-15 21:52:30 +0200
commit1eab5fcdc005c843f7e6767bb92085332e0c1650 (patch)
tree2bb4f9113447140a66b3565ec616b53e5cdedb2a /app-laptop/spicctrl
parentapp-dicts/eblook: Port to EAPI 7 (diff)
downloadgentoo-1eab5fcdc005c843f7e6767bb92085332e0c1650.tar.gz
gentoo-1eab5fcdc005c843f7e6767bb92085332e0c1650.tar.bz2
gentoo-1eab5fcdc005c843f7e6767bb92085332e0c1650.zip
app-laptop/spicctrl: Fix makefile
Closes: https://bugs.gentoo.org/742083 Package-Manager: Portage-3.0.7, Repoman-3.0.1 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-laptop/spicctrl')
-rw-r--r--app-laptop/spicctrl/files/spicctrl-1.9-makefile.patch22
-rw-r--r--app-laptop/spicctrl/spicctrl-1.9-r1.ebuild7
2 files changed, 20 insertions, 9 deletions
diff --git a/app-laptop/spicctrl/files/spicctrl-1.9-makefile.patch b/app-laptop/spicctrl/files/spicctrl-1.9-makefile.patch
index edb79ce6d9c2..ea2935d02963 100644
--- a/app-laptop/spicctrl/files/spicctrl-1.9-makefile.patch
+++ b/app-laptop/spicctrl/files/spicctrl-1.9-makefile.patch
@@ -1,11 +1,21 @@
---- a/Makefile 2012-11-20 12:38:41.528871594 +0400
-+++ b/Makefile 2012-11-20 12:39:42.630871103 +0400
-@@ -14,7 +14,7 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,6 +1,5 @@
+-CC = gcc
+-CFLAGS = -Wall -W -Wshadow -Wstrict-prototypes -Wcast-qual -Wcast-align \
+- -Wwrite-strings -O2 -pipe
++CFLAGS += -Wall -W -Wshadow -Wstrict-prototypes -Wcast-qual -Wcast-align \
++ -Wwrite-strings
+ SRC = spicctrl.c
+ OBJ = $(SRC:.c=.o)
+ LIBS =
+@@ -13,9 +12,6 @@
+
all: spicctrl
- spicctrl: $(OBJ)
+-spicctrl: $(OBJ)
- $(CC) -o spicctrl $(OBJ) $(LIBS)
-+ $(CC) $(CFLAGS) $(LDFLAGS) -o spicctrl $(OBJ) $(LIBS)
-
+-
clean:
rm -f $(OBJ) spicctrl *~
+
diff --git a/app-laptop/spicctrl/spicctrl-1.9-r1.ebuild b/app-laptop/spicctrl/spicctrl-1.9-r1.ebuild
index d08dd3d8160d..673144b0e853 100644
--- a/app-laptop/spicctrl/spicctrl-1.9-r1.ebuild
+++ b/app-laptop/spicctrl/spicctrl-1.9-r1.ebuild
@@ -13,12 +13,13 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 -ppc x86"
-PATCHES=( "${FILESDIR}/${P}-makefile.patch" )
+PATCHES=( "${FILESDIR}"/${P}-makefile.patch )
-src_compile() {
- emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+src_configure() {
+ tc-export CC
}
src_install() {
dobin spicctrl
+ einstalldocs
}