summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYongxiang Liang <tanekliang@gmail.com>2024-10-10 01:29:52 +0800
committerYixun Lan <dlan@gentoo.org>2024-10-11 08:06:41 +0800
commit442adf235ac1d4d3def1d0547ad7a5ab3ac7612e (patch)
tree53c14f4c4c460dfec52ca01af878f6a5749c6328 /app-i18n
parentapp-i18n/fcitx-qt: add 5.1.7 (diff)
downloadgentoo-442adf235ac1d4d3def1d0547ad7a5ab3ac7612e.tar.gz
gentoo-442adf235ac1d4d3def1d0547ad7a5ab3ac7612e.tar.bz2
gentoo-442adf235ac1d4d3def1d0547ad7a5ab3ac7612e.zip
app-i18n/fcitx-chinese-addons: add 5.1.7
Signed-off-by: Yongxiang Liang <tanekliang@gmail.com> Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/fcitx-chinese-addons/Manifest1
-rw-r--r--app-i18n/fcitx-chinese-addons/fcitx-chinese-addons-5.1.7.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/app-i18n/fcitx-chinese-addons/Manifest b/app-i18n/fcitx-chinese-addons/Manifest
index f9b1ea5a89dd..cfe05d92de35 100644
--- a/app-i18n/fcitx-chinese-addons/Manifest
+++ b/app-i18n/fcitx-chinese-addons/Manifest
@@ -1 +1,2 @@
DIST fcitx5-chinese-addons-5.1.6_dict.tar.zst 1005756 BLAKE2B c3b3c12c3b269c71c7136ba140fa833fb28d4ff2698213aa47bdb3fe50ee65830a99c9591180ae0bfd2873c7d84013f26df895f2574372a64cdea9ea887cb052 SHA512 f130f4492977662916a1591048832a37ec306f3664a2c5bc5225ba220ea5ffebc3ef78022b2b6d2d8475b556285a0d45508eaf00473f5b636d2e56a7c73d2f38
+DIST fcitx5-chinese-addons-5.1.7_dict.tar.zst 1014942 BLAKE2B fb386dad971b2a8751202733ef593b72d35f9ab8a266f13e6839ea25010cf54e45c287e10d285a02d268f16b5b8f7a3dc6f6f20ffcc79759d8c1ef1136a29cb5 SHA512 fe04699672f034bde328049a19f23b9dbea75a980e706fcaf95138294b8aaaee54eb9ec5c696c343d5e4ce4788216821ad3eb45cd669d94d2f3b67551ae7360f
diff --git a/app-i18n/fcitx-chinese-addons/fcitx-chinese-addons-5.1.7.ebuild b/app-i18n/fcitx-chinese-addons/fcitx-chinese-addons-5.1.7.ebuild
new file mode 100644
index 000000000000..35568fd1a173
--- /dev/null
+++ b/app-i18n/fcitx-chinese-addons/fcitx-chinese-addons-5.1.7.ebuild
@@ -0,0 +1,62 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="fcitx5-chinese-addons"
+
+inherit cmake unpacker xdg
+
+DESCRIPTION="Addons related to Chinese, including IME previous bundled inside fcitx4."
+HOMEPAGE="https://github.com/fcitx/fcitx5-chinese-addons"
+SRC_URI="https://download.fcitx-im.org/fcitx5/${MY_PN}/${MY_PN}-${PV}_dict.tar.zst"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~loong ~riscv ~x86"
+IUSE="+data +gui webengine +cloudpinyin +qt5 qt6 lua +opencc test"
+REQUIRED_USE="
+ webengine? ( gui )
+"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=app-i18n/fcitx-5.1.11:5
+ >=app-i18n/libime-1.1.7:5[data?]
+ >=dev-libs/boost-1.61:=
+ cloudpinyin? ( net-misc/curl )
+ lua? ( app-i18n/fcitx-lua:5 )
+ opencc? ( app-i18n/opencc:= )
+ gui? (
+ qt5? (
+ dev-qt/qtconcurrent:5
+ app-i18n/fcitx-qt:5[qt5,-onlyplugin]
+ webengine? ( dev-qt/qtwebengine:5[widgets] )
+ )
+ qt6? (
+ dev-qt/qtbase:6[concurrent]
+ app-i18n/fcitx-qt:5[qt6,-onlyplugin]
+ webengine? ( dev-qt/qtwebengine:6[widgets] )
+ )
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ kde-frameworks/extra-cmake-modules:0
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_BROWSER=$(usex webengine)
+ -DENABLE_CLOUDPINYIN=$(usex cloudpinyin)
+ -DENABLE_DATA=$(usex data)
+ -DENABLE_GUI=$(usex gui)
+ -DENABLE_OPENCC=$(usex opencc)
+ -DENABLE_TEST=$(usex test)
+ -DUSE_WEBKIT=no
+ -DUSE_QT6=$(usex qt6)
+ )
+ cmake_src_configure
+}