summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2021-10-29 22:52:06 +0900
committerAkinori Hattori <hattya@gentoo.org>2021-10-29 22:52:06 +0900
commit1fc61ee62272a00820f33e172785dfb179087b1c (patch)
treed3b0ac095d3cc089e48c39a82e19023b0cbcb087 /app-i18n
parentdev-libs/libxml2: drop 2.9.10-r5, 2.9.12, 2.9.12-r2, 2.9.12-r3 (diff)
downloadgentoo-1fc61ee62272a00820f33e172785dfb179087b1c.tar.gz
gentoo-1fc61ee62272a00820f33e172785dfb179087b1c.tar.bz2
gentoo-1fc61ee62272a00820f33e172785dfb179087b1c.zip
app-i18n/ibus-anthy: new upstream release
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/ibus-anthy/Manifest1
-rw-r--r--app-i18n/ibus-anthy/ibus-anthy-1.5.13.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/app-i18n/ibus-anthy/Manifest b/app-i18n/ibus-anthy/Manifest
index a5ee3abc37f6..593a1a386d16 100644
--- a/app-i18n/ibus-anthy/Manifest
+++ b/app-i18n/ibus-anthy/Manifest
@@ -1,2 +1,3 @@
DIST ibus-anthy-1.5.11.tar.gz 809725 BLAKE2B b12139e208c401e3fdda0d3a184b0246d039e077b827d1aeb2da20470deeb62551026c68ba39c289e7876467147a6ba93d318d0582a9b45866c2f5a4f52e85aa SHA512 2ac85bf4ddba56e3f84c3732082b3b63a07175ea712aad2865de4f87b8c0967da303ee1edccbed0890095e8ddab10e58307a47b72ee11b51de3927fdb9e72418
DIST ibus-anthy-1.5.12.tar.gz 825323 BLAKE2B 4d81a5885e4ad6cfc7a10ecb61bf998a76c24049e58841f84ed31f45a8ab5e91cfd2c60be3a66008f97317047487bedcf956b9126fa17602c6f8a29950687b84 SHA512 6950a2865e4753831f8918f4a5926571bc8304454b6368662ef56a6fb11a60f0675e3d589108ebfd38cb5d193f7b61053a10baa6dad23adad67b3b3fc58760e8
+DIST ibus-anthy-1.5.13.tar.gz 265252 BLAKE2B d35299dba3260b85f80f259e0a40ea1ec061ed8082b6e5c872eab6398b6242342b2ee4da0c3b191aa428ae2d8dc652b0e414fd0c9f7b93ca8dcd6303c0586b4d SHA512 058feb49b2fe50ae3ca959f4754b8070f3ebc1e6727fef4bca791aa45a23c95018000e2a8bca496d6592b052298a6fb2869a07c2cc56cc473c81cc437efa175b
diff --git a/app-i18n/ibus-anthy/ibus-anthy-1.5.13.ebuild b/app-i18n/ibus-anthy/ibus-anthy-1.5.13.ebuild
new file mode 100644
index 000000000000..feadd97d86ec
--- /dev/null
+++ b/app-i18n/ibus-anthy/ibus-anthy-1.5.13.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=( python3_{8,9} )
+
+inherit gnome2-utils python-single-r1 xdg
+
+DESCRIPTION="Japanese Anthy engine for IBus"
+HOMEPAGE="https://github.com/ibus/ibus/wiki"
+SRC_URI="https://github.com/ibus/${PN}/archive/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="nls"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ app-i18n/anthy
+ $(python_gen_cond_dep '
+ app-i18n/ibus[python(+),${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}"
+BDEPEND="sys-devel/gettext
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+ gnome2_environment_reset
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ --enable-private-png \
+ --with-layout=default \
+ --with-python=${EPYTHON}
+}
+
+src_test() {
+ :
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+
+ python_optimize
+}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+
+ if ! has_version app-dicts/kasumi; then
+ elog "app-dicts/kasumi is not required but probably useful for you."
+ fi
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}