summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-i18n/xvnkb/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-i18n/xvnkb/files')
-rw-r--r--app-i18n/xvnkb/files/0.2.8a-putenv.patch11
-rw-r--r--app-i18n/xvnkb/files/xvnkb-0.2.8a.patch16
-rw-r--r--app-i18n/xvnkb/files/xvnkb-0.2.9a-ldflags.patch34
3 files changed, 61 insertions, 0 deletions
diff --git a/app-i18n/xvnkb/files/0.2.8a-putenv.patch b/app-i18n/xvnkb/files/0.2.8a-putenv.patch
new file mode 100644
index 000000000000..ef7827e20fe8
--- /dev/null
+++ b/app-i18n/xvnkb/files/0.2.8a-putenv.patch
@@ -0,0 +1,11 @@
+--- xvnkb.c.old 2005-05-04 22:11:50.323413496 +0700
++++ xvnkb.c 2005-05-04 22:12:01.212758064 +0700
+@@ -77,7 +77,7 @@
+ static void __attribute__ ((constructor)) xvnkb_init(void)
+ {
+ static char gtk_xim_env[24] = "GTK_IM_MODULE=xim";
+- putenv(gtk_xim_env);
++ /*putenv(gtk_xim_env);*/
+ /* TODO:
+ - Initialize some more variables
+ */
diff --git a/app-i18n/xvnkb/files/xvnkb-0.2.8a.patch b/app-i18n/xvnkb/files/xvnkb-0.2.8a.patch
new file mode 100644
index 000000000000..51862a1986bd
--- /dev/null
+++ b/app-i18n/xvnkb/files/xvnkb-0.2.8a.patch
@@ -0,0 +1,16 @@
+diff -ur xvnkb-0.2.8/visckey.c xvnkb-0.2.8-new/visckey.c
+--- xvnkb-0.2.8/visckey.c 2004-01-17 05:19:17.000000000 +0700
++++ xvnkb-0.2.8-new/visckey.c 2004-03-03 04:20:44.000000000 +0700
+@@ -423,8 +423,11 @@
+ /*----------------------------------------------------------------------------*/
+ inline void VKClearBuffer()
+ {
+- tempoff = count = *word = vpc = 0;
++ tempoff = count = *word = 0;
++#ifdef VK_CHECK_SPELLING
++ vpc = 0;
+ vp = -1;
++#endif
+ }
+ /*----------------------------------------------------------------------------*/
+ inline long VKBackspaceDelete()
diff --git a/app-i18n/xvnkb/files/xvnkb-0.2.9a-ldflags.patch b/app-i18n/xvnkb/files/xvnkb-0.2.9a-ldflags.patch
new file mode 100644
index 000000000000..f089f0dde899
--- /dev/null
+++ b/app-i18n/xvnkb/files/xvnkb-0.2.9a-ldflags.patch
@@ -0,0 +1,34 @@
+diff --git a/Makefile.common b/Makefile.common
+index 06f0b78..d9f8976 100644
+--- a/Makefile.common
++++ b/Makefile.common
+@@ -19,10 +19,10 @@ all: do-it-all
+ $(CC) -fpic $(CFLAGS) $(FPTR) $(VK_OPT) -DVERSION=\"$(VERSION)\" -Wall -I$(XLIB_INC) -c $<
+
+ $(CORE): $(CORE_OBJS)
+- $(CC) $(CFLAGS) $(DLFLAGS) $(CORE_OBJS) -o $@ -L$(XLIB_PATH) $(LIBDL)
++ $(CC) $(CFLAGS) $(DLFLAGS) $(CORE_OBJS) -o $@ -L$(XLIB_PATH) $(LIBDL) $(LDFLAGS)
+
+ $(GUI): $(GUI_OBJS)
+- $(CC) $(CFLAGS) $(GUI_OBJS) -o $@ -L$(XLIB_PATH) $(LIBS) $(XFT_LIBS)
++ $(CC) $(CFLAGS) $(GUI_OBJS) -o $@ -L$(XLIB_PATH) $(LIBS) $(XFT_LIBS) $(LDFLAGS)
+
+ main: $(CORE) $(GUI)
+ @echo >/dev/null
+diff --git a/tools/Makefile.common b/tools/Makefile.common
+index fe16cc1..16ec511 100644
+--- a/tools/Makefile.common
++++ b/tools/Makefile.common
+@@ -16,10 +16,10 @@ all: do-it-all
+ $(CC) $(CFLAGS) $(DEFS) -Wall -I$(XLIB_INC) -c $<
+
+ xvnkb_ctrl: $(CONTROL_OBJS)
+- $(CC) $(CFLAGS) -o $@ $(CONTROL_OBJS) -L$(XLIB_PATH) $(LIBS)
++ $(CC) $(CFLAGS) -o $@ $(CONTROL_OBJS) -L$(XLIB_PATH) $(LIBS) $(LDFLAGS)
+
+ xvnkb_setup: $(SETUP_OBJS)
+- $(CC) $(CFLAGS) -o $@ $(SETUP_OBJS) -L$(XLIB_PATH) $(LIBS) $(XFT_LIBS)
++ $(CC) $(CFLAGS) -o $@ $(SETUP_OBJS) -L$(XLIB_PATH) $(LIBS) $(XFT_LIBS) $(LDFLAGS)
+
+ main-tools: $(TOOLS)
+