summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-03-05 23:16:43 -0500
committerSam James <sam@gentoo.org>2024-03-06 05:29:50 +0000
commit6287d789783e493e625a06a548c4691851563d36 (patch)
tree404ede021de24cbe9749a2f25491ae62485bfeb0 /app-i18n/scim-m17n
parentsci-libs/arpack: mark as LTO-unsafe (diff)
downloadgentoo-6287d789783e493e625a06a548c4691851563d36.tar.gz
gentoo-6287d789783e493e625a06a548c4691851563d36.tar.bz2
gentoo-6287d789783e493e625a06a548c4691851563d36.zip
app-i18n/scim-m17n: re-run autoreconf to fix LTO
The 2009 era distfile is so old that it probably has many bugs. We are particularly concerned by nm detection failing under LTO causing: ``` generating symbol list for `m17n.la' /usr/bin/nm -B .libs/m17n_la-scim_m17n_imengine.o | | /usr/bin/sed 's/.* //' | sort | uniq > .libs/m17n.exp ../libtool: 1: eval: Syntax error: "|" unexpected ``` Bug: https://bugs.gentoo.org/553842 Closes: https://bugs.gentoo.org/854666 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-i18n/scim-m17n')
-rw-r--r--app-i18n/scim-m17n/scim-m17n-0.2.3.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/app-i18n/scim-m17n/scim-m17n-0.2.3.ebuild b/app-i18n/scim-m17n/scim-m17n-0.2.3.ebuild
index 6fb3a51c366f..4f823e5eb9e6 100644
--- a/app-i18n/scim-m17n/scim-m17n-0.2.3.ebuild
+++ b/app-i18n/scim-m17n/scim-m17n-0.2.3.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+inherit autotools
+
DESCRIPTION="An input module for Smart Common Input Method (SCIM) which uses m17n as backend"
HOMEPAGE="http://www.scim-im.org/projects/imengines"
SRC_URI="mirror://sourceforge/scim/${P}.tar.gz"
@@ -17,6 +19,12 @@ RDEPEND=">=app-i18n/scim-1.4
DEPEND="${RDEPEND}
virtual/pkgconfig"
+src_prepare() {
+ default
+ # update the 2009 era configure / libtool scripts, which fail with LTO
+ eautoreconf
+}
+
src_configure() {
econf --disable-static
}