summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-i18n/pology
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-i18n/pology')
-rw-r--r--app-i18n/pology/Manifest2
-rw-r--r--app-i18n/pology/metadata.xml5
-rw-r--r--app-i18n/pology/pology-0.11-r1.ebuild64
-rw-r--r--app-i18n/pology/pology-0.12.ebuild61
-rw-r--r--app-i18n/pology/pology-9999.ebuild61
5 files changed, 193 insertions, 0 deletions
diff --git a/app-i18n/pology/Manifest b/app-i18n/pology/Manifest
new file mode 100644
index 000000000000..816efb91ec0c
--- /dev/null
+++ b/app-i18n/pology/Manifest
@@ -0,0 +1,2 @@
+DIST pology-0.11.tar.bz2 2064780 SHA256 ad83559f68921d7977f882e4abaf009522e834ae8f47b028309451938f05d0b4 SHA512 bc0193fd4d61390eb9fc5f0ae8eba87e4ef4a3f82f0c1cb937bc24e54cb304d208b5f57c2310291601600f97635e759e700346198637f8d155746c0baaa02b22 WHIRLPOOL 23dfbd32f4edf12d628f36c991aa1e108c2c17f6dd30d2ac201cec4a9b2152afb6696d1f1f82b77f3d407c77500d63ceb7ee8b3e53d067ec5d1aa1bb42ea0be5
+DIST pology-0.12.tar.bz2 1773467 SHA256 33fd75b7214fc70882df128b5651d4870cb7d6cc73ca27c5517b4686976de5de SHA512 2e23d1dd0c38cc17826908734adf46fb30c30d58f906fc223e2e9251791dad43d02840ae4eca55e04682af574df45a553ccd83faf85a785a1446f645e4222b4f WHIRLPOOL 04ca0259381eff932e1c32b31f2f022444733d5801e62e628d6a3bb589cf051c5fcc886cfbdc86d68cfc3ecafbb1f93d5321f3f6955a02fddbab448ee2435d65
diff --git a/app-i18n/pology/metadata.xml b/app-i18n/pology/metadata.xml
new file mode 100644
index 000000000000..a23f444b67d6
--- /dev/null
+++ b/app-i18n/pology/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>kde</herd>
+</pkgmetadata>
diff --git a/app-i18n/pology/pology-0.11-r1.ebuild b/app-i18n/pology/pology-0.11-r1.ebuild
new file mode 100644
index 000000000000..e3d5d2c0f902
--- /dev/null
+++ b/app-i18n/pology/pology-0.11-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ESVN_REPO_URI="svn://anonsvn.kde.org/home/kde/trunk/l10n-support/pology"
+PYTHON_COMPAT=( python2_7 )
+
+[[ ${PV} == 9999 ]] && VCS_ECLASS="subversion"
+
+inherit python-single-r1 cmake-utils bash-completion-r1 ${VCS_ECLASS}
+unset VCS_ECLASS
+
+DESCRIPTION="A framework for custom processing of PO files"
+HOMEPAGE="http://pology.nedohodnik.net"
+[[ ${PV} == 9999 ]] || SRC_URI="http://pology.nedohodnik.net//release/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+
+# Don't move KEYWORDS on the previous line or ekeyword won't work # 399061
+[[ ${PV} == 9999 ]] || \
+KEYWORDS="amd64 x86"
+
+IUSE=""
+
+RDEPEND="
+ dev-libs/libxslt
+ dev-libs/libxml2
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ sys-devel/gettext
+ ${PYTHON_DEPS}
+"
+DEPEND="${RDEPEND}
+ app-text/docbook-xsl-stylesheets
+ app-text/docbook-xml-dtd:4.5
+ dev-python/epydoc[${PYTHON_USEDEP}]
+"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# Magic on python parsing makes it impossible to make it parallel safe
+MAKEOPTS+=" -j1"
+
+src_prepare() {
+ python_fix_shebang .
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ dosym ../../../pology/syntax/kate/synder.xml /usr/share/apps/katepart/syntax/synder.xml
+
+ newbashcomp "${ED}"/usr/share/pology/completion/bash/pology posieve
+ bashcomp_alias {posieve,poediff}{,.py}
+
+ einfo "You should also consider following packages to install:"
+ einfo " app-text/aspell"
+ einfo " app-text/hunspell"
+ einfo " dev-vcs/git"
+ einfo " dev-vcs/subversion"
+ einfo " sci-misc/apertium"
+}
diff --git a/app-i18n/pology/pology-0.12.ebuild b/app-i18n/pology/pology-0.12.ebuild
new file mode 100644
index 000000000000..f78ef42b91ee
--- /dev/null
+++ b/app-i18n/pology/pology-0.12.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ESVN_REPO_URI="svn://anonsvn.kde.org/home/kde/trunk/l10n-support/pology"
+PYTHON_COMPAT=( python2_7 )
+
+[[ ${PV} == 9999 ]] && VCS_ECLASS="subversion"
+
+inherit python-single-r1 cmake-utils bash-completion-r1 ${VCS_ECLASS}
+unset VCS_ECLASS
+
+DESCRIPTION="A framework for custom processing of PO files"
+HOMEPAGE="http://pology.nedohodnik.net"
+[[ ${PV} == 9999 ]] || SRC_URI="http://pology.nedohodnik.net//release/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+[[ ${PV} == 9999 ]] || \
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/libxslt
+ dev-libs/libxml2
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ sys-devel/gettext
+ ${PYTHON_DEPS}
+"
+DEPEND="${RDEPEND}
+ app-text/docbook-xsl-stylesheets
+ app-text/docbook-xml-dtd:4.5
+ dev-python/epydoc[${PYTHON_USEDEP}]
+"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# Magic on python parsing makes it impossible to make it parallel safe
+MAKEOPTS+=" -j1"
+
+src_prepare() {
+ python_fix_shebang .
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ dosym ../../../pology/syntax/kate/synder.xml /usr/share/apps/katepart/syntax/synder.xml
+
+ newbashcomp "${ED}"/usr/share/pology/completion/bash/pology posieve
+ bashcomp_alias {posieve,poediff}{,.py}
+
+ einfo "You should also consider following packages to install:"
+ einfo " app-text/aspell"
+ einfo " app-text/hunspell"
+ einfo " dev-vcs/git"
+ einfo " dev-vcs/subversion"
+ einfo " sci-misc/apertium"
+}
diff --git a/app-i18n/pology/pology-9999.ebuild b/app-i18n/pology/pology-9999.ebuild
new file mode 100644
index 000000000000..f78ef42b91ee
--- /dev/null
+++ b/app-i18n/pology/pology-9999.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ESVN_REPO_URI="svn://anonsvn.kde.org/home/kde/trunk/l10n-support/pology"
+PYTHON_COMPAT=( python2_7 )
+
+[[ ${PV} == 9999 ]] && VCS_ECLASS="subversion"
+
+inherit python-single-r1 cmake-utils bash-completion-r1 ${VCS_ECLASS}
+unset VCS_ECLASS
+
+DESCRIPTION="A framework for custom processing of PO files"
+HOMEPAGE="http://pology.nedohodnik.net"
+[[ ${PV} == 9999 ]] || SRC_URI="http://pology.nedohodnik.net//release/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+[[ ${PV} == 9999 ]] || \
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/libxslt
+ dev-libs/libxml2
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ sys-devel/gettext
+ ${PYTHON_DEPS}
+"
+DEPEND="${RDEPEND}
+ app-text/docbook-xsl-stylesheets
+ app-text/docbook-xml-dtd:4.5
+ dev-python/epydoc[${PYTHON_USEDEP}]
+"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# Magic on python parsing makes it impossible to make it parallel safe
+MAKEOPTS+=" -j1"
+
+src_prepare() {
+ python_fix_shebang .
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ dosym ../../../pology/syntax/kate/synder.xml /usr/share/apps/katepart/syntax/synder.xml
+
+ newbashcomp "${ED}"/usr/share/pology/completion/bash/pology posieve
+ bashcomp_alias {posieve,poediff}{,.py}
+
+ einfo "You should also consider following packages to install:"
+ einfo " app-text/aspell"
+ einfo " app-text/hunspell"
+ einfo " dev-vcs/git"
+ einfo " dev-vcs/subversion"
+ einfo " sci-misc/apertium"
+}