summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-08-25 07:31:51 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-08-25 07:35:11 +0300
commitf000d15e32ab37449521db8932e99691f7cc594c (patch)
treecc95acada327cc81ef66c7e39b7193a48320e143 /app-i18n/nkf
parentnet-im/prosody: x86 stable wrt bug #803590 (diff)
downloadgentoo-f000d15e32ab37449521db8932e99691f7cc594c.tar.gz
gentoo-f000d15e32ab37449521db8932e99691f7cc594c.tar.bz2
gentoo-f000d15e32ab37449521db8932e99691f7cc594c.zip
app-i18n/nkf: enable py3.{9,10}, add die calls, clean deps
Closes: https://bugs.gentoo.org/800602 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-i18n/nkf')
-rw-r--r--app-i18n/nkf/nkf-2.1.5.ebuild47
1 files changed, 23 insertions, 24 deletions
diff --git a/app-i18n/nkf/nkf-2.1.5.ebuild b/app-i18n/nkf/nkf-2.1.5.ebuild
index e937e5a5aebe..7720d4a3faec 100644
--- a/app-i18n/nkf/nkf-2.1.5.ebuild
+++ b/app-i18n/nkf/nkf-2.1.5.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="7"
-PYTHON_COMPAT=( python3_{7,8} )
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
DISTUTILS_OPTIONAL="1"
-DISTUTILS_USE_SETUPTOOLS="no"
inherit distutils-r1 perl-module toolchain-funcs vcs-snapshot
@@ -22,13 +22,12 @@ KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="perl python l10n_ja"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-RDEPEND="python? (
+RDEPEND="python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}"
+BDEPEND="python? (
${PYTHON_DEPS}
- $(python_gen_cond_dep '
- dev-python/setuptools[${PYTHON_USEDEP}]
- ')
+ dev-python/setuptools[${PYTHON_USEDEP}]
)"
-DEPEND="${RDEPEND}"
src_unpack() {
use python && vcs-snapshot_src_unpack || default
@@ -42,9 +41,9 @@ src_prepare() {
if use python; then
mv "${WORKDIR}"/${PY_P} NKF.python || die
eapply "${FILESDIR}"/${PN}-python.patch
- cd NKF.python
+ cd NKF.python || die
distutils-r1_src_prepare
- cd - >/dev/null
+ cd - >/dev/null || die
fi
default
@@ -53,37 +52,37 @@ src_prepare() {
src_configure() {
default
if use perl; then
- cd NKF.mod
+ cd NKF.mod || die
perl-module_src_configure
- cd - >/dev/null
+ cd - >/dev/null || die
fi
if use python; then
- cd NKF.python
+ cd NKF.python || die
distutils-r1_src_configure
- cd - >/dev/null
+ cd - >/dev/null || die
fi
}
src_compile() {
emake CC="$(tc-getCC)"
if use perl; then
- cd NKF.mod
+ cd NKF.mod || die
perl-module_src_compile
- cd - >/dev/null
+ cd - >/dev/null || die
fi
if use python; then
- cd NKF.python
+ cd NKF.python || die
distutils-r1_src_compile
- cd - >/dev/null
+ cd - >/dev/null || die
fi
}
src_test() {
default
if use perl; then
- cd NKF.mod
+ cd NKF.mod || die
perl-module_src_test
- cd - >/dev/null
+ cd - >/dev/null || die
fi
}
@@ -98,16 +97,16 @@ src_install() {
dodoc ${PN}.doc
if use perl; then
- cd NKF.mod
+ cd NKF.mod || die
docinto perl
perl-module_src_install
- cd - >/dev/null
+ cd - >/dev/null || die
fi
if use python; then
- cd NKF.python
+ cd NKF.python || die
docinto python
DOCS= distutils-r1_src_install
dodoc CHANGES README.md
- cd - >/dev/null
+ cd - >/dev/null || die
fi
}