summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-i18n/libtabe/libtabe-0.2.6.1.2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-i18n/libtabe/libtabe-0.2.6.1.2.ebuild')
-rw-r--r--app-i18n/libtabe/libtabe-0.2.6.1.2.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/app-i18n/libtabe/libtabe-0.2.6.1.2.ebuild b/app-i18n/libtabe/libtabe-0.2.6.1.2.ebuild
new file mode 100644
index 000000000000..5372b150b369
--- /dev/null
+++ b/app-i18n/libtabe/libtabe-0.2.6.1.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+WANT_AUTOMAKE=1.11
+
+inherit eutils libtool autotools multilib versionator
+
+DEBIAN_PV=$(replace_version_separator 3 '-')
+DEBIAN_PATCH=${PN}_${DEBIAN_PV}.diff
+ORIG_PV=${DEBIAN_PV%-*}
+ORIG_P=${PN}-${ORIG_PV}
+
+DESCRIPTION="Libtabe provides bimsphone support for xcin-2.5+"
+HOMEPAGE="http://packages.qa.debian.org/libt/libtabe.html"
+SRC_URI="mirror://debian/pool/main/${PN:0:4}/${PN}/${PN}_${ORIG_PV}.orig.tar.gz
+ mirror://debian/pool/main/${PN:0:4}/libtabe/${DEBIAN_PATCH}.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE="debug"
+
+DEPEND=">=sys-libs/db-4.5
+ x11-libs/libX11"
+
+S=${WORKDIR}/${ORIG_P}.orig
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${WORKDIR}"/${DEBIAN_PATCH}
+ epatch "${FILESDIR}"/${ORIG_P}-fabs.patch
+ epatch "${FILESDIR}"/${ORIG_P}-ldflags.patch
+
+ ln -s script/configure.in . || die
+ eautoreconf
+}
+
+src_compile() {
+ myconf="--with-db-inc=/usr/include
+ --with-db-lib=/usr/$(get_libdir)
+ --with-db-bin=/usr/bin
+ --with-db-name=db
+ --enable-shared
+ --disable-static
+ $(use_enable debug)"
+
+ econf ${myconf}
+
+ # We execute this serially because the Makefiles don't handle
+ # proper cross-directory references.
+ for dir in src util tsi-src; do
+ emake -C ${dir} || die "make failed"
+ done
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc doc/* || die
+}