summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-i18n/libhangul
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-i18n/libhangul')
-rw-r--r--app-i18n/libhangul/Manifest2
-rw-r--r--app-i18n/libhangul/libhangul-0.0.12.ebuild31
-rw-r--r--app-i18n/libhangul/libhangul-0.1.0.ebuild33
-rw-r--r--app-i18n/libhangul/metadata.xml8
4 files changed, 74 insertions, 0 deletions
diff --git a/app-i18n/libhangul/Manifest b/app-i18n/libhangul/Manifest
new file mode 100644
index 000000000000..be1d718c73ac
--- /dev/null
+++ b/app-i18n/libhangul/Manifest
@@ -0,0 +1,2 @@
+DIST libhangul-0.0.12.tar.gz 2879381 SHA256 97b5ffbb9df2ddeb7ba5890824555236ed3db8bf7b78456ca7fe538bc63027c8 SHA512 5d7b84e5872fb89f7ad5f8c1a813aa6e650929eca821cf0e2b0ad831dac541f1108dd1290aa17b6dc738c40088f75ee1d1fb969f6c11ad09222c817ce50b8ade WHIRLPOOL 5727e578557e70647d2da08163dc9701a19e167cbe52ccde97f6721add6ee7d7843165f07d9a6a8049c77b15e7610e1e659d6428d7f71680354d99ae7a7a10cb
+DIST libhangul-0.1.0.tar.gz 2899845 SHA256 5905aa5c557d8d46e190fec1afdd75babf3bc086ef286b42007572703658295a SHA512 cf84850bf7a41e743457300513c5efdf7b3e18d168f4fdc324aaa8e1be78743752fcb98385764f94c707777ab82cc9444e076808e61fdbd915c9c0d7ea93c534 WHIRLPOOL 898c355f587d2943dc9044ffb46a4e4215922a8e2a7c6c36853927e924efb7e47f88ad46741fbb70a1d68547872f2a3db77926cfe9c78ed6171095cd0a466f28
diff --git a/app-i18n/libhangul/libhangul-0.0.12.ebuild b/app-i18n/libhangul/libhangul-0.0.12.ebuild
new file mode 100644
index 000000000000..00facf07994d
--- /dev/null
+++ b/app-i18n/libhangul/libhangul-0.0.12.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+DESCRIPTION="libhangul is a generalized and portable library for processing hangul"
+HOMEPAGE="http://kldp.net/projects/hangul/"
+SRC_URI="http://kldp.net/frs/download.php/5855/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ppc ~ppc64 x86"
+IUSE="nls static-libs test"
+
+RDEPEND="nls? ( virtual/libintl )"
+DEPEND="nls? ( sys-devel/gettext )
+ virtual/pkgconfig
+ test? ( dev-libs/check )"
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable static-libs static) || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS ChangeLog NEWS README || die
+}
diff --git a/app-i18n/libhangul/libhangul-0.1.0.ebuild b/app-i18n/libhangul/libhangul-0.1.0.ebuild
new file mode 100644
index 000000000000..f149e3b4e60c
--- /dev/null
+++ b/app-i18n/libhangul/libhangul-0.1.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+DESCRIPTION="libhangul is a generalized and portable library for processing hangul"
+HOMEPAGE="http://code.google.com/p/libhangul/"
+SRC_URI="http://libhangul.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ppc64 x86"
+IUSE="nls static-libs test"
+
+RDEPEND="nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+ test? ( dev-libs/check )"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ rm -f "${ED}"/usr/lib*/libhangul.la
+}
diff --git a/app-i18n/libhangul/metadata.xml b/app-i18n/libhangul/metadata.xml
new file mode 100644
index 000000000000..7264771eb8f1
--- /dev/null
+++ b/app-i18n/libhangul/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>cjk</herd>
+ <upstream>
+ <remote-id type="google-code">libhangul</remote-id>
+ </upstream>
+</pkgmetadata>