summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2017-08-17 00:07:51 +0900
committerAkinori Hattori <hattya@gentoo.org>2017-08-17 00:07:51 +0900
commitfa2170a27949a469409308cb1153f6ef0212d877 (patch)
treea182cd8645b7bcbba475cc83ddaab5ae7638bce5 /app-i18n/libchewing
parentdev-libs/libchewing: move to app-i18n/libchewing (diff)
downloadgentoo-fa2170a27949a469409308cb1153f6ef0212d877.tar.gz
gentoo-fa2170a27949a469409308cb1153f6ef0212d877.tar.bz2
gentoo-fa2170a27949a469409308cb1153f6ef0212d877.zip
app-i18n/libchewing: update to EAPI 6
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'app-i18n/libchewing')
-rw-r--r--app-i18n/libchewing/libchewing-0.4.0-r1.ebuild29
1 files changed, 10 insertions, 19 deletions
diff --git a/app-i18n/libchewing/libchewing-0.4.0-r1.ebuild b/app-i18n/libchewing/libchewing-0.4.0-r1.ebuild
index a2a73dc6986f..526dc209f753 100644
--- a/app-i18n/libchewing/libchewing-0.4.0-r1.ebuild
+++ b/app-i18n/libchewing/libchewing-0.4.0-r1.ebuild
@@ -1,45 +1,36 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI="6"
-inherit autotools eutils multilib toolchain-funcs
+inherit autotools ltprune
DESCRIPTION="Library for Chinese Phonetic input method"
HOMEPAGE="http://chewing.csie.net/"
-SRC_URI="https://github.com/chewing/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="https://github.com/${PN/lib}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="amd64 ~ppc ppc64 ~x86"
IUSE="static-libs test"
-DEPEND="
+RDEPEND="dev-db/sqlite:3"
+DEPEND="${RDEPEND}
virtual/pkgconfig
test? (
+ dev-libs/check
sys-libs/ncurses[unicode]
- >=dev-libs/check-0.9.4
- )
- dev-db/sqlite:3
-"
-
-DOCS=( AUTHORS NEWS README.md TODO )
+ )"
src_prepare() {
+ default
eautoreconf
}
src_configure() {
econf \
$(use_enable static-libs static) \
- --with-sqlite3 \
- --disable-gcov
-}
-
-src_test() {
- # test subdirectory is not enabled by default; this means that we
- # have to make it explicit.
- emake -C test check
+ --with-sqlite3
}
src_install() {