summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-i18n/fcitx-unikey
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-i18n/fcitx-unikey')
-rw-r--r--app-i18n/fcitx-unikey/Manifest2
-rw-r--r--app-i18n/fcitx-unikey/fcitx-unikey-0.2.0.ebuild39
-rw-r--r--app-i18n/fcitx-unikey/fcitx-unikey-0.2.4.ebuild34
-rw-r--r--app-i18n/fcitx-unikey/files/fcitx-unikey-0.2.0-cmake-qt-option.patch56
-rw-r--r--app-i18n/fcitx-unikey/metadata.xml5
5 files changed, 136 insertions, 0 deletions
diff --git a/app-i18n/fcitx-unikey/Manifest b/app-i18n/fcitx-unikey/Manifest
new file mode 100644
index 000000000000..eef4f12d026f
--- /dev/null
+++ b/app-i18n/fcitx-unikey/Manifest
@@ -0,0 +1,2 @@
+DIST fcitx-unikey-0.2.0.tar.xz 70944 SHA256 152da48ffeb665fc5d88202f6491fa5f4d11284792c2ef079bea4a94c8b125e1 SHA512 10c5c2c5b7e4f40710daccc485b220ed4cdadc6e866636032873a86f9f8489490a42671c9d02aedbbda78a94e40801dd888efc9b692d26ff81fe6d1fe2e10fa7 WHIRLPOOL d6dfd445bd5aa98ec28ab0bd9668f288d67f27874ecdd079f78956172f3d5695fd990ce9e70f190a26edd1eab4f48a8263efc8682fe93679a85fc1db2f6745be
+DIST fcitx-unikey-0.2.4.tar.xz 72308 SHA256 726e5999c00e93856639258298688c835db1e80e4ac4d5ff0786433c0593c195 SHA512 d55fe71bbcbc420e0ba3ec61ad3c7e9293e33f30b6303d90591d5a94e89d7bbc513dc940ae5a081b81c0d973fa6674872a695eac03cfbbefb460609993219221 WHIRLPOOL 9178a4ec7bcf0b6f969295bef0b066b266e336352c52f9a8761cb1cb6456df6c3d90a90d90212c2fbe137ebc07a1cf6b79f82e959dc6ad3806158675ee040fbb
diff --git a/app-i18n/fcitx-unikey/fcitx-unikey-0.2.0.ebuild b/app-i18n/fcitx-unikey/fcitx-unikey-0.2.0.ebuild
new file mode 100644
index 000000000000..4e28e9c12825
--- /dev/null
+++ b/app-i18n/fcitx-unikey/fcitx-unikey-0.2.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils gnome2-utils
+
+DESCRIPTION="Vietnamese Unikey module for Fcitx"
+HOMEPAGE="http://fcitx-im.org/"
+SRC_URI="http://fcitx.googlecode.com/files/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 ppc ~ppc64 x86"
+IUSE="+qt4"
+
+RDEPEND=">=app-i18n/fcitx-4.2.7[qt4?]"
+DEPEND="${RDEPEND}
+ sys-devel/gettext"
+
+src_prepare() {
+ # Add cmake option to build the qt based macro editor or not
+ epatch "${FILESDIR}/${P}-cmake-qt-option.patch"
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_enable qt4 QT)
+ )
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/app-i18n/fcitx-unikey/fcitx-unikey-0.2.4.ebuild b/app-i18n/fcitx-unikey/fcitx-unikey-0.2.4.ebuild
new file mode 100644
index 000000000000..e829fd226be7
--- /dev/null
+++ b/app-i18n/fcitx-unikey/fcitx-unikey-0.2.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils gnome2-utils
+
+DESCRIPTION="Vietnamese Unikey module for Fcitx"
+HOMEPAGE="http://fcitx-im.org/"
+SRC_URI="http://download.fcitx-im.org/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ppc64 ~x86"
+IUSE="+qt4"
+
+RDEPEND=">=app-i18n/fcitx-4.2.8[qt4?]"
+DEPEND="${RDEPEND}
+ sys-devel/gettext"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_enable qt4 QT)
+ )
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/app-i18n/fcitx-unikey/files/fcitx-unikey-0.2.0-cmake-qt-option.patch b/app-i18n/fcitx-unikey/files/fcitx-unikey-0.2.0-cmake-qt-option.patch
new file mode 100644
index 000000000000..2667b0cd0d11
--- /dev/null
+++ b/app-i18n/fcitx-unikey/files/fcitx-unikey-0.2.0-cmake-qt-option.patch
@@ -0,0 +1,56 @@
+From f0f0d7c1ee5d83f33ceacaf78f4b7845ec2819de Mon Sep 17 00:00:00 2001
+From: Weng Xuetian <wengxt@gmail.com>
+Date: Sat, 26 Jan 2013 14:45:29 -0500
+Subject: [PATCH] [unikey] option for qt, detect qt 4.8
+
+---
+ CMakeLists.txt | 7 ++++++-
+ macro-editor/CMakeLists.txt | 4 ++--
+ 2 files changed, 8 insertions(+), 3 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index cef1625..5ccf21c 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -4,6 +4,8 @@ project(fcitx-unikey)
+
+ set(CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/cmake" ${CMAKE_MODULE_PATH})
+
++option(ENABLE_QT "Enable Qt based macro editor" On)
++
+ # uninstall target
+ configure_file(
+ "${CMAKE_CURRENT_SOURCE_DIR}/cmake/cmake_uninstall.cmake.in"
+@@ -21,9 +23,12 @@ set(CMAKE_MODULE_LINKER_FLAGS "-Wl,--as-needed ${CMAKE_MODULE_LINKER_FLAGS}")
+ find_package(Fcitx 4.2.7 REQUIRED)
+ find_package(Libiconv REQUIRED)
+ find_package(Gettext REQUIRED)
+-find_package(Qt4)
++
++if (ENABLE_QT)
++find_package(Qt4 4.8)
+
+ pkg_check_modules(FCITX_QT "fcitx-qt>=4.2.7")
++endif (ENABLE_QT)
+
+ configure_file(config.h.in config.h)
+
+diff --git a/macro-editor/CMakeLists.txt b/macro-editor/CMakeLists.txt
+index fbb2482..145ee0b 100644
+--- a/macro-editor/CMakeLists.txt
++++ b/macro-editor/CMakeLists.txt
+@@ -16,9 +16,9 @@ fcitx_translate_add_sources(
+ ${MACRO_EDITOR_SRCS}
+ ${MACRO_EDITOR_HDRS})
+
+-if (NOT QT_FOUND OR NOT FCITX_QT_FOUND)
++if (NOT QT_FOUND OR NOT FCITX_QT_FOUND OR NOT ENABLE_QT)
+ return()
+-endif (NOT QT_FOUND OR NOT FCITX_QT_FOUND)
++endif (NOT QT_FOUND OR NOT FCITX_QT_FOUND OR NOT ENABLE_QT)
+
+ include_directories(
+ ${FCITX_QT_INCLUDE_DIRS}
+--
+1.7.10
+
diff --git a/app-i18n/fcitx-unikey/metadata.xml b/app-i18n/fcitx-unikey/metadata.xml
new file mode 100644
index 000000000000..cb36a2fd8c76
--- /dev/null
+++ b/app-i18n/fcitx-unikey/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>cjk</herd>
+</pkgmetadata>