summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-i18n/fcitx-rime
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-i18n/fcitx-rime')
-rw-r--r--app-i18n/fcitx-rime/Manifest2
-rw-r--r--app-i18n/fcitx-rime/fcitx-rime-0.2.0.ebuild34
-rw-r--r--app-i18n/fcitx-rime/fcitx-rime-0.3.1.ebuild34
-rw-r--r--app-i18n/fcitx-rime/metadata.xml13
4 files changed, 83 insertions, 0 deletions
diff --git a/app-i18n/fcitx-rime/Manifest b/app-i18n/fcitx-rime/Manifest
new file mode 100644
index 000000000000..dba3d2464649
--- /dev/null
+++ b/app-i18n/fcitx-rime/Manifest
@@ -0,0 +1,2 @@
+DIST fcitx-rime-0.2.0.tar.xz 8116 SHA256 e4bc9243abffd1851b4ee19c88d7c2b32ede134aeda60aee930388f9f33ca269 SHA512 3f02d7bf0e47981e7a135ccaa46653be319d1bb716bd939b50419e47b8d3c07b347434e8529522d4266bd5fac6dbc2cdc1bfd4b7ea0607250023f70f97006228 WHIRLPOOL 7dbdcd3ac90f2d901b5b5c06541b9f6f1debf4ad833c2ddacb840dbd80a4443725fc7bdb41ad2261db8f34cb0dc77fe3d5f0c45e69a0a056618518007c1c708e
+DIST fcitx-rime-0.3.1.tar.xz 39648 SHA256 3ca74de4d20e8fd0e67eb4ccae8af3790bb1f557f183c2af32cb45f371e8521d SHA512 5d3c8fc119e1a104987a7876f3b1c54da074e34ce9feb9c02efa7c9cfd788c3735680a03cdb50d69a5512a9f075c7326bdc267cf076daa916238898da81d2388 WHIRLPOOL ed8f4ed563dfbe01aaac71bb847d4a9b641b041f9916c8c6c34a444202ac00720ebe4274c30906141b103fbbf55d7ce045cef094792c1fffadae03dd0ce73f7a
diff --git a/app-i18n/fcitx-rime/fcitx-rime-0.2.0.ebuild b/app-i18n/fcitx-rime/fcitx-rime-0.2.0.ebuild
new file mode 100644
index 000000000000..25335a90966b
--- /dev/null
+++ b/app-i18n/fcitx-rime/fcitx-rime-0.2.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="Rime support for Fcitx"
+HOMEPAGE="http://fcitx-im.org/"
+SRC_URI="https://fcitx.googlecode.com/files/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 x86"
+IUSE=""
+
+RDEPEND=">=app-i18n/fcitx-4.2.7
+ app-i18n/librime
+ app-i18n/rime-data
+ x11-libs/libnotify"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ # dont build data resource here, already provided by app-i18n/rime-data
+ sed -i -e 's|add_subdirectory(data)||' CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DRIME_DATA_DIR=/usr/share/rime-data
+ )
+ cmake-utils_src_configure
+}
diff --git a/app-i18n/fcitx-rime/fcitx-rime-0.3.1.ebuild b/app-i18n/fcitx-rime/fcitx-rime-0.3.1.ebuild
new file mode 100644
index 000000000000..8b1623ca36bd
--- /dev/null
+++ b/app-i18n/fcitx-rime/fcitx-rime-0.3.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="Rime support for Fcitx"
+HOMEPAGE="http://fcitx-im.org/"
+SRC_URI="http://download.fcitx-im.org/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ppc64 ~x86"
+IUSE=""
+
+RDEPEND=">=app-i18n/fcitx-4.2.8.1
+ >=app-i18n/librime-1.0
+ app-i18n/rime-data
+ x11-libs/libnotify"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ # dont build data resource here, already provided by app-i18n/rime-data
+ sed -i -e 's|add_subdirectory(data)||' CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DRIME_DATA_DIR=/usr/share/rime-data
+ )
+ cmake-utils_src_configure
+}
diff --git a/app-i18n/fcitx-rime/metadata.xml b/app-i18n/fcitx-rime/metadata.xml
new file mode 100644
index 000000000000..91091e17d28b
--- /dev/null
+++ b/app-i18n/fcitx-rime/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>cjk</herd>
+ <maintainer>
+ <email>dlan@gentoo.org</email>
+ <name>Yixun Lan</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>http://code.google.com/p/rimeime/issues/list</bugs-to>
+ <remote-id type="google-code">rimeime</remote-id>
+ </upstream>
+</pkgmetadata>