summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2016-08-05 13:19:04 +0200
committerMike Gilbert <floppym@gentoo.org>2016-08-06 13:25:39 -0400
commit5da22d2ab16d27ac66d1b26d172435cf8cb45013 (patch)
tree47210b7167f8f0442089c3c79368b4546da7c59c /app-i18n/fcitx-m17n/fcitx-m17n-9999.ebuild
parentDrop package.use.mask on ruby use flag for subversion-1.7 as the 1.7 series h... (diff)
downloadgentoo-5da22d2ab16d27ac66d1b26d172435cf8cb45013.tar.gz
gentoo-5da22d2ab16d27ac66d1b26d172435cf8cb45013.tar.bz2
gentoo-5da22d2ab16d27ac66d1b26d172435cf8cb45013.zip
app-i18n/fcitx-m17n: Initial addition.
Diffstat (limited to 'app-i18n/fcitx-m17n/fcitx-m17n-9999.ebuild')
-rw-r--r--app-i18n/fcitx-m17n/fcitx-m17n-9999.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-i18n/fcitx-m17n/fcitx-m17n-9999.ebuild b/app-i18n/fcitx-m17n/fcitx-m17n-9999.ebuild
new file mode 100644
index 000000000000..78afc5b98a5e
--- /dev/null
+++ b/app-i18n/fcitx-m17n/fcitx-m17n-9999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+inherit cmake-utils
+
+if [[ "${PV}" == "9999" ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/fcitx/fcitx-m17n"
+fi
+
+DESCRIPTION="m17n-provided input methods for Fcitx"
+HOMEPAGE="https://fcitx-im.org/ https://github.com/fcitx/fcitx-m17n"
+if [[ "${PV}" == "9999" ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://download.fcitx-im.org/${PN}/${P}.tar.xz"
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND=">=app-i18n/fcitx-4.2.8
+ dev-libs/m17n-lib
+ virtual/libintl"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=()