summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2017-09-26 22:53:08 +0200
committerMike Gilbert <floppym@gentoo.org>2017-09-27 15:56:58 -0400
commitc7784acea9b02e03532a6d650fcb4ec9cda67135 (patch)
tree2de89b2b037efff38da36b99d76f42869b1c68f9 /app-i18n/fcitx-configtool/fcitx-configtool-4.9999.ebuild
parentapp-i18n/fcitx-chewing: Use ${Fcitx_major_version}.9999 version scheme for li... (diff)
downloadgentoo-c7784acea9b02e03532a6d650fcb4ec9cda67135.tar.gz
gentoo-c7784acea9b02e03532a6d650fcb4ec9cda67135.tar.bz2
gentoo-c7784acea9b02e03532a6d650fcb4ec9cda67135.zip
app-i18n/fcitx-configtool: Use ${Fcitx_major_version}.9999 version scheme for live ebuild.
Diffstat (limited to 'app-i18n/fcitx-configtool/fcitx-configtool-4.9999.ebuild')
-rw-r--r--app-i18n/fcitx-configtool/fcitx-configtool-4.9999.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-i18n/fcitx-configtool/fcitx-configtool-4.9999.ebuild b/app-i18n/fcitx-configtool/fcitx-configtool-4.9999.ebuild
new file mode 100644
index 000000000000..aa0e86bd5706
--- /dev/null
+++ b/app-i18n/fcitx-configtool/fcitx-configtool-4.9999.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit cmake-utils
+
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/fcitx/fcitx-configtool"
+fi
+
+DESCRIPTION="GTK+ GUI configuration tool for Fcitx"
+HOMEPAGE="https://fcitx-im.org/ https://github.com/fcitx/fcitx-configtool"
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://download.fcitx-im.org/${PN}/${P}.tar.xz"
+fi
+
+LICENSE="GPL-2+"
+SLOT="4"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND=">=app-i18n/fcitx-4.2.9:4
+ app-text/iso-codes
+ dev-libs/glib:2
+ x11-libs/gtk+:3"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=()
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_GTK2=OFF
+ -DENABLE_GTK3=ON
+ )
+
+ cmake-utils_src_configure
+}