summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2023-08-04 10:20:38 -0400
committerMike Pagano <mpagano@gentoo.org>2023-08-04 10:20:38 -0400
commitd216c3ccebee8b34aa12e2f7efbca5bd1799d814 (patch)
treeb01c0b8638a183363da060a0999e0f2f29afc580 /app-forensics/lynis
parentx11-terms/xterm: Stabilize 383 ppc, #911631 (diff)
downloadgentoo-d216c3ccebee8b34aa12e2f7efbca5bd1799d814.tar.gz
gentoo-d216c3ccebee8b34aa12e2f7efbca5bd1799d814.tar.bz2
gentoo-d216c3ccebee8b34aa12e2f7efbca5bd1799d814.zip
app-forensics/lynis: add 3.0.9
Signed-off-by: Mike Pagano <mpagano@gentoo.org>
Diffstat (limited to 'app-forensics/lynis')
-rw-r--r--app-forensics/lynis/Manifest1
-rw-r--r--app-forensics/lynis/lynis-3.0.9.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/app-forensics/lynis/Manifest b/app-forensics/lynis/Manifest
index 8ebbc512db93..12f931895573 100644
--- a/app-forensics/lynis/Manifest
+++ b/app-forensics/lynis/Manifest
@@ -1 +1,2 @@
DIST lynis-3.0.8.tar.gz 339467 BLAKE2B 490bd6799619a4247c3fa68cc96f2f1fead651b23db0ffb512394960f8ca0360ab7f25d2bb8d9e742641558972e1fdd4b1e18d7de0d13007988276eed3a97b1f SHA512 df41aa8b7518a72ee17732eb7e69ccc62ca6e1323d3adc7aec509cd1c21494fece873e101bc317655dafbf58b32699f56dd27eec13a2ce615801cee75961cd33
+DIST lynis-3.0.9.tar.gz 339171 BLAKE2B dc7912c7d1782c3ffdf369cc7f0f004267bd2a2c408982909e654db14ecfa83ebdbd2f731c3d3ee8864e7de21945b1faa2f9d2845dedf3e742a4c79c62373eda SHA512 7fc0349be9ea9d6e311b834cb7f9089bd0d393381edb5325a0bea88ed83dcd3d816dc213c6a6d17f88ff937af71be72004570894e427e4faf1b0d39448aa3a43
diff --git a/app-forensics/lynis/lynis-3.0.9.ebuild b/app-forensics/lynis/lynis-3.0.9.ebuild
new file mode 100644
index 000000000000..8ed08f4c8527
--- /dev/null
+++ b/app-forensics/lynis/lynis-3.0.9.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+inherit bash-completion-r1 systemd
+
+DESCRIPTION="Security and system auditing tool"
+HOMEPAGE="https://cisofy.com/lynis/"
+SRC_URI="https://cisofy.com/files/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+cron systemd"
+
+DEPEND=""
+RDEPEND="
+ app-shells/bash
+ cron? ( !systemd? ( virtual/cron ) )"
+
+S="${WORKDIR}/${PN}"
+
+src_install() {
+ doman lynis.8
+ dodoc FAQ README
+ newdoc CHANGELOG.md CHANGELOG
+
+ # Remove the old one during the next stabilize progress
+ exeinto /etc/cron.daily
+ newexe "${FILESDIR}"/lynis.cron-new lynis
+
+ dobashcomp extras/bash_completion.d/lynis
+
+ # stricter default perms - bug 507436
+ diropts -m0700
+ insopts -m0600
+
+ insinto /usr/share/${PN}
+ doins -r db/ include/ plugins/
+
+ dosbin lynis
+
+ insinto /etc/${PN}
+ doins default.prf
+ sed -i -e 's/\/path\/to\///' "${S}/extras/systemd/${PN}.service" || die "Sed Failed!"
+ systemd_dounit "${S}/extras/systemd/${PN}.service" || die "Sed Failed!"
+ systemd_dounit "${S}/extras/systemd/${PN}.timer"
+
+ if ! use cron; then
+ ebegin "removing cron files from installation image"
+ rm -rfv "${ED}/etc/cron.daily" || die
+ eend "$?"
+ fi
+}
+
+pkg_postinst() {
+ if use cron; then
+ if systemd_is_booted || has_version sys-apps/systemd; then
+ echo
+ ewarn "Both 'cron' and 'systemd' flags are enabled."
+ ewarn "So both ${PN}.target and cron files were installed."
+ ewarn "Please don't use 2 implementations at the same time."
+ ewarn "Cronjobs are usually enabled by default via /etc/cron.* jobs"
+ ewarn "If you want to use systemd ${PN}.target timers"
+ ewarn "disable 'cron' flag and reinstall ${PN}"
+ echo
+ else
+ einfo "A cron script has been installed to ${ROOT}/etc/cron.daily/lynis."
+ fi
+ fi
+}