summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2023-10-25 23:52:16 +0100
committerMarek Szuba <marecki@gentoo.org>2023-10-25 23:54:02 +0100
commite257c631d861262da90defb2d143fe5f866f76d0 (patch)
treefbcb83264f1d9f913f4b52745e59c2d727f7c797 /app-emulation
parentdev-python/python-rtmidi: add 1.5.7 (diff)
downloadgentoo-e257c631d861262da90defb2d143fe5f866f76d0.tar.gz
gentoo-e257c631d861262da90defb2d143fe5f866f76d0.tar.bz2
gentoo-e257c631d861262da90defb2d143fe5f866f76d0.zip
app-emulation/protontricks: add 1.10.5
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/protontricks/Manifest1
-rw-r--r--app-emulation/protontricks/protontricks-1.10.5.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/app-emulation/protontricks/Manifest b/app-emulation/protontricks/Manifest
index ac15507ba590..8b98ae43195a 100644
--- a/app-emulation/protontricks/Manifest
+++ b/app-emulation/protontricks/Manifest
@@ -1 +1,2 @@
DIST protontricks-1.10.3.tar.gz 162698 BLAKE2B 7e3f696f3589a4a92d2cc6132132546bc0c38a5110d688cd486c2d52bd37275b8df4085edc38d4876583aa0d5ec0a9de599ca05616bf92812decf624e2259406 SHA512 c389a712bcbb9dace8e6b3fa10ddb9db0a67abbd3b8d000d312fd59bb682aa68c10d5411b10b31948967536418e56116ac435054ff6d6999bc471ba2a97ca6ba
+DIST protontricks-1.10.5.tar.gz 163931 BLAKE2B 299fd6c77460de3d2fa1b585a1ad3dae857e4b78898c753007b358cc25b82918d33cb31c2028a4b1b562ee6c20b95ebafc532d97e2bc1fa5358464c6a4c1da5c SHA512 305b27ceaf428946a0ed09994173c861da1097c0bd21eebcc8b255bed3c4c50a920f0cc422601fbd44e0af373b71e928096fdd6f4cc2aa05c88126212fb4401f
diff --git a/app-emulation/protontricks/protontricks-1.10.5.ebuild b/app-emulation/protontricks/protontricks-1.10.5.ebuild
new file mode 100644
index 000000000000..cbecf711b3cf
--- /dev/null
+++ b/app-emulation/protontricks/protontricks-1.10.5.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 pypi xdg-utils
+
+DESCRIPTION="app-emulation/winetricks wrapper for Proton (Steam Play) games"
+HOMEPAGE="https://github.com/Matoking/protontricks"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+gui"
+
+RDEPEND="app-emulation/winetricks
+ $(python_gen_cond_dep '
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/vdf[${PYTHON_USEDEP}]
+ ')
+ gui? ( gnome-extra/zenity
+ || (
+ app-emulation/winetricks[gtk]
+ app-emulation/winetricks[kde]
+ )
+ )"
+BDEPEND="$(python_gen_cond_dep '
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+')"
+
+DOCS=( CHANGELOG.md README.md )
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ xdg_desktop_database_update
+
+ elog
+
+ if ! use gui; then
+ ewarn "Please note that disabling USE=gui does *not* presently remove the --gui command-line option,"
+ ewarn "it just means using this option will fail unless gnome-extra/zenity happens to be installed."
+ ewarn
+ fi
+
+ elog "Protontricks can only find games for which a Proton prefix already exists."
+ elog "Make sure to run a Proton game at least once before trying to use protontricks on it."
+ elog
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}