summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-10-24 18:09:23 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-10-24 18:09:23 -0400
commitdd282d16bbe9a3c73e1ccd34831a5f2b483ef387 (patch)
tree260c397841fb511f0fbe651f662e77c0d454bdb2 /app-emulation
parentmedia-radio/chirp: drop 20230818, 20230823 (diff)
downloadgentoo-dd282d16bbe9a3c73e1ccd34831a5f2b483ef387.tar.gz
gentoo-dd282d16bbe9a3c73e1ccd34831a5f2b483ef387.tar.bz2
gentoo-dd282d16bbe9a3c73e1ccd34831a5f2b483ef387.zip
app-emulation/wine-mono: add 8.1.0
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/wine-mono/Manifest2
-rw-r--r--app-emulation/wine-mono/wine-mono-8.1.0.ebuild26
2 files changed, 28 insertions, 0 deletions
diff --git a/app-emulation/wine-mono/Manifest b/app-emulation/wine-mono/Manifest
index b882c2b34735..f611e6a731de 100644
--- a/app-emulation/wine-mono/Manifest
+++ b/app-emulation/wine-mono/Manifest
@@ -8,3 +8,5 @@ DIST wine-mono-8.0.0-x86.msi 84587008 BLAKE2B ad2e94b89ef40497009b3a4c1df368482a
DIST wine-mono-8.0.0-x86.tar.xz 42360588 BLAKE2B ef3ffceb788bb5683de105c20741be8d2ac63622edfa22cd60bf6fb5833ecab19b51ba5fe1ff6cd1a30425fd26ff861e4ad2d5eaf97d38251f66e88e54ab04ea SHA512 7ffa8a87c9e23d84fee789da83f29480d91b79915d3acaa15803699d8ee1575097e24c38fb0e23b22fc5b67f64287fa3f7979b1a077c08ed2f5b69643dcacd4f
DIST wine-mono-8.0.1-x86.msi 84579328 BLAKE2B 946a0bf5a7e4fef8c6d40a9899a070fb4d6542ed6f4c632ded4edeab134e7fd6c17f1951cd3008b51c7f56eab95c0120bbf64212361a64653fb7bd4d54512a15 SHA512 06aed1bf24882987cd2eae99f9295faf450e0c1471381105ce794987cf37bb7feb7bc857e4dcd59a718b05b1676f227bf16abb472c1d1fc7f1902ec835de3156
DIST wine-mono-8.0.1-x86.tar.xz 42365644 BLAKE2B 53ae5cb57c4571aa7071d13b99af59b24b2275c559fd062a2621413b1e17a3d0a2bda23f143df6dd2b7685e65d62ab8e800fd3f082be02faac54450c8d71faf1 SHA512 bd174ce5031df1a13a6cb050b735d32330ccd0de43ea29888a91c49db49b02f9b377e78ef9531eaa1b30eed79c6706d84624b87d784f73224581763ca9e63945
+DIST wine-mono-8.1.0-x86.msi 84905984 BLAKE2B 948b014fc6fba94bc97642b8aae266b8179b119ea3d8a0fdf47daee33eac65b8cc5dd1bc483ae4c66bdd1bdc10f4b73258bb6c83bca0911a30e86e358faafd20 SHA512 5c788dfa0c9b664242f3ce0ab24f3f9256dabf1e9fadc516140f267c763da1865b4536c707660acaf66e4a37d93198f5499971b4261e63d91252f6a7fc3eae4e
+DIST wine-mono-8.1.0-x86.tar.xz 40854944 BLAKE2B 0e0dd83b92016da328547173d25dc396a895a7a161cd54796c9bda34ae958856f1bee342c1bb5fcffcf695b35adf66b2bf83cfa61e01790bf4b0f2d198f84feb SHA512 ba87105a6527b9c392e9ad406e92fd90164e0abb3a348a1e343e63eff0ee8632399badb98f7fbc3581ce697ba09d98aafbf5033bf52fb14b7c7c280c64f25a84
diff --git a/app-emulation/wine-mono/wine-mono-8.1.0.ebuild b/app-emulation/wine-mono/wine-mono-8.1.0.ebuild
new file mode 100644
index 000000000000..96896ce732cf
--- /dev/null
+++ b/app-emulation/wine-mono/wine-mono-8.1.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Replacement for the .NET runtime and class libraries in Wine"
+HOMEPAGE="https://wiki.winehq.org/Mono"
+SRC_URI="
+ shared? ( https://github.com/madewokherd/wine-mono/releases/download/${P}/${P}-x86.tar.xz )
+ !shared? ( https://github.com/madewokherd/wine-mono/releases/download/${P}/${P}-x86.msi )"
+S="${WORKDIR}"
+
+LICENSE="BSD-2 GPL-2 LGPL-2.1 MIT MPL-1.1"
+SLOT="${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+shared"
+
+src_install() {
+ insinto /usr/share/wine/mono
+
+ if use shared; then
+ doins -r ${P}
+ else
+ doins "${DISTDIR}"/${P}-x86.msi
+ fi
+}