summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-08-14 06:17:51 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-08-14 06:25:46 -0400
commitd01071c8fd157a5d26cec16cd618a906e158cbad (patch)
tree3f52be84b1a50c0b122961e3bf08efd65288d702 /app-emulation
parentapp-misc/fastfetch: sync live (diff)
downloadgentoo-d01071c8fd157a5d26cec16cd618a906e158cbad.tar.gz
gentoo-d01071c8fd157a5d26cec16cd618a906e158cbad.tar.bz2
gentoo-d01071c8fd157a5d26cec16cd618a906e158cbad.zip
app-emulation/wine-vanilla: pass -mno-avx with mingw unconditionally
Upon further consideration 9bef96cec566f1e06f5e9c40e52785b7b9702afa result in rather unexpected behavior even if we consider that USE=custom-cflags is unsupported, and giving a way to skip -mno-avx may not be all that worth it. So revert plus tidy and add this bugref. Closes: https://bugs.gentoo.org/912268 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-7.0.2.ebuild4
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-8.0.1.ebuild7
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-8.0.2.ebuild7
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-8.11-r1.ebuild4
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-8.12.ebuild4
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-8.13.ebuild2
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-9999.ebuild2
7 files changed, 21 insertions, 9 deletions
diff --git a/app-emulation/wine-vanilla/wine-vanilla-7.0.2.ebuild b/app-emulation/wine-vanilla/wine-vanilla-7.0.2.ebuild
index ddff00b2ea43..3ce352533b56 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-7.0.2.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-7.0.2.ebuild
@@ -283,11 +283,13 @@ src_configure() {
: "${CROSSCFLAGS:=$(
filter-flags '-fstack-protector*' #870136
filter-flags '-mfunction-return=thunk*' #878849
+
# -mavx with mingw-gcc has a history of obscure issues and
# disabling is seen as safer, e.g. `WINEARCH=win32 winecfg`
# crashes with -march=skylake >=wine-8.10, similar issues with
# znver4: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=110273
- use custom-cflags || append-cflags -mno-avx
+ append-cflags -mno-avx #912268
+
CC=${CROSSCC} test-flags-CC ${CFLAGS:--O2})}"
: "${CROSSLDFLAGS:=$(
filter-flags '-fuse-ld=*'
diff --git a/app-emulation/wine-vanilla/wine-vanilla-8.0.1.ebuild b/app-emulation/wine-vanilla/wine-vanilla-8.0.1.ebuild
index fff16211ef70..364fb01af774 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-8.0.1.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-8.0.1.ebuild
@@ -282,14 +282,17 @@ src_configure() {
# use *FLAGS for mingw, but strip unsupported
: "${CROSSCFLAGS:=$(
# >=wine-7.21 configure.ac no longer adds -fno-strict by mistake
- append-cflags '-fno-strict-aliasing'
+ append-cflags -fno-strict-aliasing
+
filter-flags '-fstack-protector*' #870136
filter-flags '-mfunction-return=thunk*' #878849
+
# -mavx with mingw-gcc has a history of obscure issues and
# disabling is seen as safer, e.g. `WINEARCH=win32 winecfg`
# crashes with -march=skylake >=wine-8.10, similar issues with
# znver4: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=110273
- use custom-cflags || append-cflags -mno-avx
+ append-cflags -mno-avx #912268
+
CC=${CROSSCC} test-flags-CC ${CFLAGS:--O2})}"
: "${CROSSLDFLAGS:=$(
filter-flags '-fuse-ld=*'
diff --git a/app-emulation/wine-vanilla/wine-vanilla-8.0.2.ebuild b/app-emulation/wine-vanilla/wine-vanilla-8.0.2.ebuild
index fb1ab81d78d7..b95ead30f8be 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-8.0.2.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-8.0.2.ebuild
@@ -282,14 +282,17 @@ src_configure() {
# use *FLAGS for mingw, but strip unsupported
: "${CROSSCFLAGS:=$(
# >=wine-7.21 configure.ac no longer adds -fno-strict by mistake
- append-cflags '-fno-strict-aliasing'
+ append-cflags -fno-strict-aliasing
+
filter-flags '-fstack-protector*' #870136
filter-flags '-mfunction-return=thunk*' #878849
+
# -mavx with mingw-gcc has a history of obscure issues and
# disabling is seen as safer, e.g. `WINEARCH=win32 winecfg`
# crashes with -march=skylake >=wine-8.10, similar issues with
# znver4: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=110273
- use custom-cflags || append-cflags -mno-avx
+ append-cflags -mno-avx #912268
+
CC=${CROSSCC} test-flags-CC ${CFLAGS:--O2})}"
: "${CROSSLDFLAGS:=$(
filter-flags '-fuse-ld=*'
diff --git a/app-emulation/wine-vanilla/wine-vanilla-8.11-r1.ebuild b/app-emulation/wine-vanilla/wine-vanilla-8.11-r1.ebuild
index ba2f5e2f4c08..5221f7e79d76 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-8.11-r1.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-8.11-r1.ebuild
@@ -289,11 +289,13 @@ src_configure() {
: "${CROSSCFLAGS:=$(
filter-flags '-fstack-protector*' #870136
filter-flags '-mfunction-return=thunk*' #878849
+
# -mavx with mingw-gcc has a history of obscure issues and
# disabling is seen as safer, e.g. `WINEARCH=win32 winecfg`
# crashes with -march=skylake >=wine-8.10, similar issues with
# znver4: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=110273
- use custom-cflags || append-cflags -mno-avx
+ append-cflags -mno-avx #912268
+
CC=${CROSSCC} test-flags-CC ${CFLAGS:--O2})}"
: "${CROSSLDFLAGS:=$(
filter-flags '-fuse-ld=*'
diff --git a/app-emulation/wine-vanilla/wine-vanilla-8.12.ebuild b/app-emulation/wine-vanilla/wine-vanilla-8.12.ebuild
index ba2f5e2f4c08..5221f7e79d76 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-8.12.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-8.12.ebuild
@@ -289,11 +289,13 @@ src_configure() {
: "${CROSSCFLAGS:=$(
filter-flags '-fstack-protector*' #870136
filter-flags '-mfunction-return=thunk*' #878849
+
# -mavx with mingw-gcc has a history of obscure issues and
# disabling is seen as safer, e.g. `WINEARCH=win32 winecfg`
# crashes with -march=skylake >=wine-8.10, similar issues with
# znver4: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=110273
- use custom-cflags || append-cflags -mno-avx
+ append-cflags -mno-avx #912268
+
CC=${CROSSCC} test-flags-CC ${CFLAGS:--O2})}"
: "${CROSSLDFLAGS:=$(
filter-flags '-fuse-ld=*'
diff --git a/app-emulation/wine-vanilla/wine-vanilla-8.13.ebuild b/app-emulation/wine-vanilla/wine-vanilla-8.13.ebuild
index 3822698583f1..c6b837670cbb 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-8.13.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-8.13.ebuild
@@ -297,7 +297,7 @@ src_configure() {
# disabling is seen as safer, e.g. `WINEARCH=win32 winecfg`
# crashes with -march=skylake >=wine-8.10, similar issues with
# znver4: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=110273
- use custom-cflags || append-cflags -mno-avx
+ append-cflags -mno-avx #912268
CC=${mingwcc} test-flags-CC ${CFLAGS:--O2}
)}"
diff --git a/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild b/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild
index 3822698583f1..c6b837670cbb 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild
@@ -297,7 +297,7 @@ src_configure() {
# disabling is seen as safer, e.g. `WINEARCH=win32 winecfg`
# crashes with -march=skylake >=wine-8.10, similar issues with
# znver4: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=110273
- use custom-cflags || append-cflags -mno-avx
+ append-cflags -mno-avx #912268
CC=${mingwcc} test-flags-CC ${CFLAGS:--O2}
)}"