summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2021-08-07 13:30:19 +0200
committerLouis Sautier <sbraz@gentoo.org>2021-08-23 01:00:10 +0200
commita7a79b82d38c779754a945e63f1b032c120a7d87 (patch)
tree4c4f99a1f1a5b72852e83bd983686d26f0fa0c8e /app-emulation
parentapp-cdr/dolphin-plugins-mountiso: remove unused patch(es) (diff)
downloadgentoo-a7a79b82d38c779754a945e63f1b032c120a7d87.tar.gz
gentoo-a7a79b82d38c779754a945e63f1b032c120a7d87.tar.bz2
gentoo-a7a79b82d38c779754a945e63f1b032c120a7d87.zip
app-emulation/docker-compose: enable py3.10, use epytest
Also rely on distutils_enable_tests to set RESTRICT and IUSE. Closes: https://github.com/gentoo/gentoo/pull/21905 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/docker-compose/docker-compose-1.29.2.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/app-emulation/docker-compose/docker-compose-1.29.2.ebuild b/app-emulation/docker-compose/docker-compose-1.29.2.ebuild
index cec99a23828b..f61fc3f500ac 100644
--- a/app-emulation/docker-compose/docker-compose-1.29.2.ebuild
+++ b/app-emulation/docker-compose/docker-compose-1.29.2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8..10} )
DISTUTILS_USE_SETUPTOOLS=rdepend
inherit bash-completion-r1 distutils-r1
@@ -16,10 +16,8 @@ SRC_URI="https://github.com/docker/compose/archive/${MY_PV}.tar.gz -> ${P}.tar.g
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="amd64 arm64"
-IUSE="test"
-RESTRICT="!test? ( test )"
-RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+RDEPEND="
>=dev-python/cached-property-1.2.0[${PYTHON_USEDEP}]
>=dev-python/distro-1.5.0[${PYTHON_USEDEP}]
>=dev-python/docker-py-5[${PYTHON_USEDEP}]
@@ -43,6 +41,8 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/compose-${MY_PV}"
+distutils_enable_tests pytest
+
PATCHES=(
# Bug #679968 -- https://bugs.gentoo.org/679968
# Bug #681002 -- https://bugs.gentoo.org/681002
@@ -60,7 +60,7 @@ src_prepare() {
python_test() {
distutils_install_for_testing
- ${PYTHON} -m pytest tests/unit/ || die "tests failed under ${EPYTHON}"
+ epytest tests/unit/
}
python_install_all() {