summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2019-08-21 11:07:50 -0700
committerZac Medico <zmedico@gentoo.org>2019-08-21 11:12:23 -0700
commit93707f197335ee979fd22226bdacdd73f216e0a2 (patch)
treed8189a26f2834d936f78249208580bad2f4b885c /app-emulation
parentapp-emulation/conmon: Remove old version 0.2.0 (diff)
downloadgentoo-93707f197335ee979fd22226bdacdd73f216e0a2.tar.gz
gentoo-93707f197335ee979fd22226bdacdd73f216e0a2.tar.bz2
gentoo-93707f197335ee979fd22226bdacdd73f216e0a2.zip
app-emulation/conmon: Bump to version 2.0.0
Package-Manager: Portage-2.3.72, Repoman-2.3.17 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/conmon/Manifest1
-rw-r--r--app-emulation/conmon/conmon-2.0.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/app-emulation/conmon/Manifest b/app-emulation/conmon/Manifest
index c02b4cdfa5de..cd01138500aa 100644
--- a/app-emulation/conmon/Manifest
+++ b/app-emulation/conmon/Manifest
@@ -1,2 +1,3 @@
DIST conmon-0.3.0.tar.gz 49021 BLAKE2B ca753f8fe0801cef4e392e2f60e58c51100628f0576c46d139c9c9827a927970ec63bb0aaebce6ac6ffaedae75b141730833b8adcafc8d9777900d96319edff3 SHA512 9a60f3eace596a8d12dc950597a9e3619a6728bf4555bb1636da3ac8ed8a6bc2ae28471cba9c7c3ad04b61a24aa4bbd28242a22940240bf27babb834031deea4
DIST conmon-0.4.0.tar.gz 48889 BLAKE2B 50bfa534d04428b422902ab3cd4feec5cb1cf7a6411eb35fc2420680eccc95dd17d7cd1ed8af904f6d246f10511b23b69ff112fee70d3a734098fcd7f5d7d7e7 SHA512 6aa9e0f72231bd890df4f4fe96b8831ad0fcb3e1f0edef74af8471aa227aefc3d8ea20d8bf0d50a6c06913c6360970464ea1b44fb68c77dbcc2da55073704bdd
+DIST conmon-2.0.0.tar.gz 51805 BLAKE2B 4c9e89c7d2339c82eda41b35f014ef392e185a28e93e81770bb1b9c629709c9b20ce0e7d78a0a1e2a68193e791ec45e70d427d8f4533adf5817bf806e919b524 SHA512 0d903f1b83248a130fa6a5c212f96a5bcc37113cfb93c73847a3744b9da8ca355f93f16ca57f4bfb50bcba13b272f23970fdec8ab7ac1862e93b3057512e572b
diff --git a/app-emulation/conmon/conmon-2.0.0.ebuild b/app-emulation/conmon/conmon-2.0.0.ebuild
new file mode 100644
index 000000000000..2f415a695537
--- /dev/null
+++ b/app-emulation/conmon/conmon-2.0.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KEYWORDS="~amd64"
+DESCRIPTION="An OCI container runtime monitor"
+HOMEPAGE="https://github.com/containers/conmon"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="systemd"
+EGIT_COMMIT="e217fdff82e0b1a6184a28c43043a4065083407f"
+SRC_URI="${HOMEPAGE}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+RDEPEND="dev-libs/glib:=
+ systemd? ( sys-apps/systemd:= )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+
+ if ! use systemd; then
+ sed -e 's| $(PKG_CONFIG) --exists libsystemd-journal | false |' \
+ -e 's| $(PKG_CONFIG) --exists libsystemd | false |' \
+ -i Makefile || die
+ fi
+}
+
+src_compile() {
+ emake GIT_COMMIT="${EGIT_COMMIT}" \
+ all
+}
+
+src_install() {
+ emake DESTDIR="${D}" \
+ PREFIX="/usr" \
+ install
+ dodir /usr/libexec/podman
+ ln "${ED}/usr/"{bin,libexec/podman}/conmon || die
+ dodoc README.md
+}