summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChema Alonso Josa <nimiux@gentoo.org>2018-04-09 22:24:00 +0200
committerChema Alonso Josa <nimiux@gentoo.org>2018-04-09 22:24:24 +0200
commit852dc477fc07ab24afd2423dc55edf9a0ff7f635 (patch)
tree9705b309b3d5dd9be2b0699d778fe389e206c6cd /app-emulation
parentdev-python/jaraco-packaging: arm64 stable, bug #641304 (diff)
downloadgentoo-852dc477fc07ab24afd2423dc55edf9a0ff7f635.tar.gz
gentoo-852dc477fc07ab24afd2423dc55edf9a0ff7f635.tar.bz2
gentoo-852dc477fc07ab24afd2423dc55edf9a0ff7f635.zip
app-emulation/free42: Version bump to 2.0.20
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/free42/Manifest1
-rw-r--r--app-emulation/free42/free42-2.0.20.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/app-emulation/free42/Manifest b/app-emulation/free42/Manifest
index 7ee23b5f829b..e71f35a310a4 100644
--- a/app-emulation/free42/Manifest
+++ b/app-emulation/free42/Manifest
@@ -1,2 +1,3 @@
DIST free42-nologo-2.0.10.tgz 7389429 BLAKE2B a633a78ed5974e327aafa9d783c04bdcaa895940580c595c9c67ab0181ec7000efaa92021a485199268341f15f4c4bafe3964d4118c068e8abbfa2f358045b5a SHA512 4f03b9b206ef17e71295f0baac96ca26f34a00844cee6cad254f8ab798d3d0c724788200f3f207a3301f62eb0960707a23e6bcbb2ac924a78b0f0e1c78e70e6d
DIST free42-nologo-2.0.17.tgz 7389996 BLAKE2B cc7c7bbe43eafc190fe0ce8921e032c2042290fe54a3153ba7568dae315de1356a9ee7f8ded4528788c677537138a5bd5556ad79dbd67ab8e41dd881a258312e SHA512 f73bfb2984fa4301c04d905fde6723583a57a1f663e012f965037067a7259961c0134fecb456118ec4b45956f7c8ccc16f0ec1db62e4cc705dc74ea563225872
+DIST free42-nologo-2.0.20.tgz 7390214 BLAKE2B 306f3378bcbb44fa7982c5d9c29bfbea62e915ca50ca5e5216f46fbf483f110a1288d4800991a74622a042517496ff8dd94c3fa3249e8bb4181957e6b23d5ea3 SHA512 9b540fbc50df2f94b135b5e778354f330df77a54ef2ad99b257b5b91d1e3e8d1241e8a834522fc46fe33571ea2695ad8889b427dbcf653870672e89cd56d60f5
diff --git a/app-emulation/free42/free42-2.0.20.ebuild b/app-emulation/free42/free42-2.0.20.ebuild
new file mode 100644
index 000000000000..e19a9ce48c9a
--- /dev/null
+++ b/app-emulation/free42/free42-2.0.20.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils toolchain-funcs
+
+MY_PV="${PN}-nologo-${PV}"
+
+DESCRIPTION="An HP-42S Calculator Simulator"
+HOMEPAGE="http://thomasokken.com/free42/"
+SRC_URI="http://thomasokken.com/free42/upstream/${MY_PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa"
+
+DEPEND="dev-libs/atk
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:2
+ x11-libs/pango
+ alsa? ( media-libs/alsa-lib )"
+
+RDEPEND="${DEPEND}
+ x11-libs/libX11
+ x11-libs/libXmu"
+
+S="${WORKDIR}/${MY_PV}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.0.10-fix-makefile.patch"
+ "${FILESDIR}/${PN}-2.0.10-fix-build-intel-lib.patch"
+)
+
+src_prepare() {
+ default
+}
+
+src_compile() {
+ local myconf
+ use alsa && myconf="AUDIO_ALSA=yes"
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" BCD_MATH=1 ${myconf} -C "${S}/gtk"
+}
+
+src_install() {
+ dodoc CREDITS HISTORY README
+ dobin gtk/free42dec
+}