summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-01-16 13:01:30 +0100
committerLars Wendler <polynomial-c@gentoo.org>2019-01-16 13:02:39 +0100
commit64ef1ea0da5b2f6698afdfd2c2204fa1b40f7e12 (patch)
treeb0ccae4f1981374345ee0248291cb2c0d3527e0d /app-emulation
parentsys-fs/btrfs-progs: Removed old. (diff)
downloadgentoo-64ef1ea0da5b2f6698afdfd2c2204fa1b40f7e12.tar.gz
gentoo-64ef1ea0da5b2f6698afdfd2c2204fa1b40f7e12.tar.bz2
gentoo-64ef1ea0da5b2f6698afdfd2c2204fa1b40f7e12.zip
app-emulation/virtualbox: Fixed build against dev-libs/libressl.
Closes: https://bugs.gentoo.org/673800 Package-Manager: Portage-2.3.56, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/virtualbox/files/virtualbox-6.0.0-libressl.patch24
-rw-r--r--app-emulation/virtualbox/virtualbox-6.0.0.ebuild3
-rw-r--r--app-emulation/virtualbox/virtualbox-6.0.2.ebuild1
3 files changed, 27 insertions, 1 deletions
diff --git a/app-emulation/virtualbox/files/virtualbox-6.0.0-libressl.patch b/app-emulation/virtualbox/files/virtualbox-6.0.0-libressl.patch
new file mode 100644
index 000000000000..a79ae1ddf683
--- /dev/null
+++ b/app-emulation/virtualbox/files/virtualbox-6.0.0-libressl.patch
@@ -0,0 +1,24 @@
+https://bugs.gentoo.org/673800
+
+diff --git a/src/VBox/Runtime/common/crypto/ssl-openssl.cpp b/src/VBox/Runtime/common/crypto/ssl-openssl.cpp
+index e6d58b75..b2422983 100644
+--- a/src/VBox/Runtime/common/crypto/ssl-openssl.cpp
++++ b/src/VBox/Runtime/common/crypto/ssl-openssl.cpp
+@@ -271,7 +271,7 @@ RTDECL(int) RTCrSslCreateSessionForNativeSocket(RTCRSSL hSsl, RTHCINTPTR hNative
+ pSession->pBio = BIO_new_socket(hNativeSocket, BIO_NOCLOSE);
+ if (pSession->pBio)
+ {
+-# if OPENSSL_VERSION_NUMBER >= 0x10100000
++# if (OPENSSL_VERSION_NUMBER >= 0x10100000 && !defined(LIBRESSL_VERSION_NUMBER)) || LIBRESSL_VERSION_NUMBER >= 0x2070000f
+ BIO_up_ref(pSession->pBio); /* our reference. */
+ # endif
+ SSL_set_bio(pSession->pSsl, pSession->pBio, pSession->pBio);
+@@ -319,7 +319,7 @@ static int rtCrSslSessionDestroy(RTCRSSLSESSIONINT *pThis)
+ ASMAtomicWriteU32(&pThis->u32Magic, ~RTCRSSLSESSIONINT_MAGIC);
+ SSL_free(pThis->pSsl);
+ pThis->pSsl = NULL;
+-# if OPENSSL_VERSION_NUMBER >= 0x10100000
++# if (OPENSSL_VERSION_NUMBER >= 0x10100000 && !defined(LIBRESSL_VERSION_NUMBER)) || LIBRESSL_VERSION_NUMBER >= 0x2070000f
+ BIO_free(pThis->pBio);
+ # endif
+ pThis->pBio = NULL;
diff --git a/app-emulation/virtualbox/virtualbox-6.0.0.ebuild b/app-emulation/virtualbox/virtualbox-6.0.0.ebuild
index 09faed602e03..6cd4dce30fea 100644
--- a/app-emulation/virtualbox/virtualbox-6.0.0.ebuild
+++ b/app-emulation/virtualbox/virtualbox-6.0.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -195,6 +195,7 @@ src_prepare() {
fi
eapply "${WORKDIR}/patches"
+ eapply "${FILESDIR}"/${PN}-6.0.0-libressl.patch #673800
eapply_user
}
diff --git a/app-emulation/virtualbox/virtualbox-6.0.2.ebuild b/app-emulation/virtualbox/virtualbox-6.0.2.ebuild
index 77317e5778d5..699ab42ad4c4 100644
--- a/app-emulation/virtualbox/virtualbox-6.0.2.ebuild
+++ b/app-emulation/virtualbox/virtualbox-6.0.2.ebuild
@@ -199,6 +199,7 @@ src_prepare() {
rm "${WORKDIR}/patches/010_virtualbox-5.2.12-qt511.patch" || die
eapply "${WORKDIR}/patches"
+ eapply "${FILESDIR}"/${PN}-6.0.0-libressl.patch #673800
eapply_user
}