summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatoro Mahri <matoro_gentoo@matoro.tk>2023-12-19 23:37:49 -0500
committerSam James <sam@gentoo.org>2023-12-28 02:56:10 +0000
commit55ca8d7b6a9d6d64a76ec5ab1b222dae7dbde51c (patch)
treeabe053abe26a1e4b96f8237e44b16fc5bfbf43da /app-emulation
parentdev-util/perf: mirror kernel restrictions for libdw support (diff)
downloadgentoo-55ca8d7b6a9d6d64a76ec5ab1b222dae7dbde51c.tar.gz
gentoo-55ca8d7b6a9d6d64a76ec5ab1b222dae7dbde51c.tar.bz2
gentoo-55ca8d7b6a9d6d64a76ec5ab1b222dae7dbde51c.zip
app-emulation/qemu: require CONFIG_IP_MULTICAST for test suite
Bug: https://bugs.gentoo.org/914827 Signed-off-by: Matoro Mahri <matoro_gentoo@matoro.tk> Closes: https://github.com/gentoo/gentoo/pull/34380 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/qemu/qemu-8.0.5.ebuild2
-rw-r--r--app-emulation/qemu/qemu-8.1.2.ebuild2
-rw-r--r--app-emulation/qemu/qemu-8.1.3.ebuild2
-rw-r--r--app-emulation/qemu/qemu-9999.ebuild2
4 files changed, 8 insertions, 0 deletions
diff --git a/app-emulation/qemu/qemu-8.0.5.ebuild b/app-emulation/qemu/qemu-8.0.5.ebuild
index 438e63f95e5b..ec208b855eb0 100644
--- a/app-emulation/qemu/qemu-8.0.5.ebuild
+++ b/app-emulation/qemu/qemu-8.0.5.ebuild
@@ -396,6 +396,8 @@ pkg_pretend() {
use vhost-net && CONFIG_CHECK+=" ~VHOST_NET"
ERROR_VHOST_NET="You must enable VHOST_NET to have vhost-net"
ERROR_VHOST_NET+=" support"
+ use test && CONFIG_CHECK+=" IP_MULTICAST"
+ ERROR_IP_MULTICAST="Test suite requires IP_MULTICAST"
if use amd64 || use x86 || use amd64-linux || use x86-linux; then
if grep -q AuthenticAMD /proc/cpuinfo; then
diff --git a/app-emulation/qemu/qemu-8.1.2.ebuild b/app-emulation/qemu/qemu-8.1.2.ebuild
index 2ea790325cf1..9557c4eff16f 100644
--- a/app-emulation/qemu/qemu-8.1.2.ebuild
+++ b/app-emulation/qemu/qemu-8.1.2.ebuild
@@ -396,6 +396,8 @@ pkg_pretend() {
use vhost-net && CONFIG_CHECK+=" ~VHOST_NET"
ERROR_VHOST_NET="You must enable VHOST_NET to have vhost-net"
ERROR_VHOST_NET+=" support"
+ use test && CONFIG_CHECK+=" IP_MULTICAST"
+ ERROR_IP_MULTICAST="Test suite requires IP_MULTICAST"
if use amd64 || use x86 || use amd64-linux || use x86-linux; then
if grep -q AuthenticAMD /proc/cpuinfo; then
diff --git a/app-emulation/qemu/qemu-8.1.3.ebuild b/app-emulation/qemu/qemu-8.1.3.ebuild
index 2ea790325cf1..9557c4eff16f 100644
--- a/app-emulation/qemu/qemu-8.1.3.ebuild
+++ b/app-emulation/qemu/qemu-8.1.3.ebuild
@@ -396,6 +396,8 @@ pkg_pretend() {
use vhost-net && CONFIG_CHECK+=" ~VHOST_NET"
ERROR_VHOST_NET="You must enable VHOST_NET to have vhost-net"
ERROR_VHOST_NET+=" support"
+ use test && CONFIG_CHECK+=" IP_MULTICAST"
+ ERROR_IP_MULTICAST="Test suite requires IP_MULTICAST"
if use amd64 || use x86 || use amd64-linux || use x86-linux; then
if grep -q AuthenticAMD /proc/cpuinfo; then
diff --git a/app-emulation/qemu/qemu-9999.ebuild b/app-emulation/qemu/qemu-9999.ebuild
index cef7e03b44b6..41fbe471c0c9 100644
--- a/app-emulation/qemu/qemu-9999.ebuild
+++ b/app-emulation/qemu/qemu-9999.ebuild
@@ -401,6 +401,8 @@ pkg_pretend() {
use vhost-net && CONFIG_CHECK+=" ~VHOST_NET"
ERROR_VHOST_NET="You must enable VHOST_NET to have vhost-net"
ERROR_VHOST_NET+=" support"
+ use test && CONFIG_CHECK+=" IP_MULTICAST"
+ ERROR_IP_MULTICAST="Test suite requires IP_MULTICAST"
if use amd64 || use x86 || use amd64-linux || use x86-linux; then
if grep -q AuthenticAMD /proc/cpuinfo; then