summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2021-08-04 02:34:33 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2021-08-04 02:36:42 -0700
commit1ea780e78b89e07a1c6a50ec069d3cfb68e23a63 (patch)
tree5d18d46f9050469b89a2e6f341b4f7f2c217620b /app-emulation
parentx11-terms/cool-retro-term: drop slyfox@ from maintainers down to m-n (diff)
downloadgentoo-1ea780e78b89e07a1c6a50ec069d3cfb68e23a63.tar.gz
gentoo-1ea780e78b89e07a1c6a50ec069d3cfb68e23a63.tar.bz2
gentoo-1ea780e78b89e07a1c6a50ec069d3cfb68e23a63.zip
app-emulation/crun: revbump, fix libcrun underlinking.
Bug: https://bugs.gentoo.org/717750 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/crun/crun-0.19.1-r1.ebuild (renamed from app-emulation/crun/crun-0.19.1.ebuild)9
-rw-r--r--app-emulation/crun/files/libcrun-linkage.patch29
2 files changed, 38 insertions, 0 deletions
diff --git a/app-emulation/crun/crun-0.19.1.ebuild b/app-emulation/crun/crun-0.19.1-r1.ebuild
index 36091c997004..0590fee263af 100644
--- a/app-emulation/crun/crun-0.19.1.ebuild
+++ b/app-emulation/crun/crun-0.19.1-r1.ebuild
@@ -36,6 +36,15 @@ RESTRICT="test"
DOCS=( README.md )
+PATCHES=( "${FILESDIR}/libcrun-linkage.patch" )
+
+src_prepare() {
+ default
+
+ # for libcrun-linkage.patch
+ eautoreconf
+}
+
src_configure() {
local myeconfargs=(
$(use_enable bpf)
diff --git a/app-emulation/crun/files/libcrun-linkage.patch b/app-emulation/crun/files/libcrun-linkage.patch
new file mode 100644
index 000000000000..72156ac931c8
--- /dev/null
+++ b/app-emulation/crun/files/libcrun-linkage.patch
@@ -0,0 +1,29 @@
+From 7cfdf094071fcff038bab573c1eeee599fa17b16 Mon Sep 17 00:00:00 2001
+From: Georgy Yakovlev <gyakovlev@gentoo.org>
+Date: Mon, 2 Aug 2021 03:53:25 -0700
+Subject: [PATCH] Makefile.am: link libcrun to $(FOUND_LIBS)
+
+otherwise libcrun consumers fail at runtime with
+symbol lookup errors
+
+Closes: https://github.com/containers/crun/issues/711
+Issue: https://github.com/containers/crun/issues/340
+Downstream-bug: https://bugs.gentoo.org/717750
+Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
+---
+ Makefile.am | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index 150e933a..7e5a4406 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -46,7 +46,7 @@ libocispec/libocispec.la:
+
+ libcrun_la_SOURCES = $(libcrun_SOURCES)
+ libcrun_la_CFLAGS = -I $(abs_top_builddir)/libocispec/src -I $(abs_top_srcdir)/libocispec/src -fvisibility=hidden
+-libcrun_la_LIBADD = libocispec/libocispec.la $(maybe_libyajl.la)
++libcrun_la_LIBADD = libocispec/libocispec.la $(FOUND_LIBS) $(maybe_libyajl.la)
+ libcrun_la_LDFLAGS = -Wl,--version-script=$(abs_top_srcdir)/libcrun.lds
+
+ # build a version with all the symbols visible for testing