summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-06-24 10:53:51 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-06-24 11:04:01 -0400
commitb6c0730a41163808e0df5fec7a528e5347e2e53f (patch)
tree2fe01295f7bd6816dc048a77ea9b2eb9e21eeb4e /app-emulation/wine-staging
parentdev-python/graph-tool: drop 2.46 (diff)
downloadgentoo-b6c0730a41163808e0df5fec7a528e5347e2e53f.tar.gz
gentoo-b6c0730a41163808e0df5fec7a528e5347e2e53f.tar.bz2
gentoo-b6c0730a41163808e0df5fec7a528e5347e2e53f.zip
app-emulation/wine-staging: add workaround for smart-live-rebuild
Tentative fix for smart-live-rebuild ignoring wine-staging-9999 (believed to be due to seeing EGIT_COMMIT). Not tested, but should work in theory. Could mark them local but want to ensure nothing git-r3_src_unpack set was preserved to be sure. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-emulation/wine-staging')
-rw-r--r--app-emulation/wine-staging/wine-staging-9999.ebuild14
1 files changed, 9 insertions, 5 deletions
diff --git a/app-emulation/wine-staging/wine-staging-9999.ebuild b/app-emulation/wine-staging/wine-staging-9999.ebuild
index c811b766776f..a11cbb764ad0 100644
--- a/app-emulation/wine-staging/wine-staging-9999.ebuild
+++ b/app-emulation/wine-staging/wine-staging-9999.ebuild
@@ -180,11 +180,15 @@ src_unpack() {
EGIT_CHECKOUT_DIR=${WORKDIR}/${P}
git-r3_src_unpack
- EGIT_COMMIT=$(<"${EGIT_CHECKOUT_DIR}"/staging/upstream-commit) || die
- EGIT_REPO_URI=${WINE_EGIT_REPO_URI}
- EGIT_CHECKOUT_DIR=${S}
- einfo "Fetching Wine commit matching the current patchset by default (${EGIT_COMMIT})"
- git-r3_src_unpack
+ # hack: use subshell to preserve state (including what git-r3 unpack
+ # sets) for smart-live-rebuild as this is not the repo to look at
+ (
+ EGIT_COMMIT=$(<"${EGIT_CHECKOUT_DIR}"/staging/upstream-commit) || die
+ EGIT_REPO_URI=${WINE_EGIT_REPO_URI}
+ EGIT_CHECKOUT_DIR=${S}
+ einfo "Fetching Wine commit matching the current patchset by default (${EGIT_COMMIT})"
+ git-r3_src_unpack
+ )
else
default
fi