summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-08-13 15:32:35 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-08-13 15:39:17 -0400
commit7e6eea87603252f3b2688e02730ba9a8230477d1 (patch)
tree7e4023170b6d8b11d17d740f88d716cb3c4558fd /app-emulation/wine-staging
parentapp-emulation/wine-vanilla: adjust comments w/ bugref for clang (diff)
downloadgentoo-7e6eea87603252f3b2688e02730ba9a8230477d1.tar.gz
gentoo-7e6eea87603252f3b2688e02730ba9a8230477d1.tar.bz2
gentoo-7e6eea87603252f3b2688e02730ba9a8230477d1.zip
app-emulation/wine-staging: adjust comments w/ bugref for clang
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-emulation/wine-staging')
-rw-r--r--app-emulation/wine-staging/wine-staging-8.0.ebuild2
-rw-r--r--app-emulation/wine-staging/wine-staging-8.11-r1.ebuild2
-rw-r--r--app-emulation/wine-staging/wine-staging-8.12.ebuild2
-rw-r--r--app-emulation/wine-staging/wine-staging-8.13.ebuild3
-rw-r--r--app-emulation/wine-staging/wine-staging-9999.ebuild3
5 files changed, 7 insertions, 5 deletions
diff --git a/app-emulation/wine-staging/wine-staging-8.0.ebuild b/app-emulation/wine-staging/wine-staging-8.0.ebuild
index 9b2fa68aa6e5..02e21b401e18 100644
--- a/app-emulation/wine-staging/wine-staging-8.0.ebuild
+++ b/app-emulation/wine-staging/wine-staging-8.0.ebuild
@@ -208,7 +208,7 @@ src_prepare() {
# drop as a quick fix for now which hopefully should be safe
sed -i '/MSVCRTFLAGS=/s/-mabi=ms//' configure.ac || die
else
- # ./configure will abort looking for -mabi=ms, so do it early
+ # known broken due to bug #912237, require mingw for now
die "building ${PN} with clang requires USE=mingw to be enabled"
fi
fi
diff --git a/app-emulation/wine-staging/wine-staging-8.11-r1.ebuild b/app-emulation/wine-staging/wine-staging-8.11-r1.ebuild
index f2f9ddf5ead8..3de52318a359 100644
--- a/app-emulation/wine-staging/wine-staging-8.11-r1.ebuild
+++ b/app-emulation/wine-staging/wine-staging-8.11-r1.ebuild
@@ -221,7 +221,7 @@ src_prepare() {
# drop as a quick fix for now which hopefully should be safe
sed -i '/MSVCRTFLAGS=/s/-mabi=ms//' configure.ac || die
else
- # ./configure will abort looking for -mabi=ms, so do it early
+ # known broken due to bug #912237, require mingw for now
die "building ${PN} with clang requires USE=mingw to be enabled"
fi
fi
diff --git a/app-emulation/wine-staging/wine-staging-8.12.ebuild b/app-emulation/wine-staging/wine-staging-8.12.ebuild
index f2f9ddf5ead8..3de52318a359 100644
--- a/app-emulation/wine-staging/wine-staging-8.12.ebuild
+++ b/app-emulation/wine-staging/wine-staging-8.12.ebuild
@@ -221,7 +221,7 @@ src_prepare() {
# drop as a quick fix for now which hopefully should be safe
sed -i '/MSVCRTFLAGS=/s/-mabi=ms//' configure.ac || die
else
- # ./configure will abort looking for -mabi=ms, so do it early
+ # known broken due to bug #912237, require mingw for now
die "building ${PN} with clang requires USE=mingw to be enabled"
fi
fi
diff --git a/app-emulation/wine-staging/wine-staging-8.13.ebuild b/app-emulation/wine-staging/wine-staging-8.13.ebuild
index bf30ea0d2af9..beaa12265098 100644
--- a/app-emulation/wine-staging/wine-staging-8.13.ebuild
+++ b/app-emulation/wine-staging/wine-staging-8.13.ebuild
@@ -41,6 +41,7 @@ IUSE="
+truetype udev udisks +unwind usb v4l +vulkan wayland wow64
+xcomposite xinerama"
# bug #551124 for truetype
+# TODO: wow64 can be done without mingw if using clang (needs bug #912237)
REQUIRED_USE="
X? ( truetype )
crossdev-mingw? ( mingw )
@@ -233,7 +234,7 @@ src_prepare() {
# drop as a quick fix for now which hopefully should be safe
sed -i '/MSVCRTFLAGS=/s/-mabi=ms//' configure.ac || die
else
- # ./configure will abort looking for -mabi=ms, so do it early
+ # known broken due to bug #912237, require mingw for now
die "building ${PN} with clang requires USE=mingw to be enabled"
fi
fi
diff --git a/app-emulation/wine-staging/wine-staging-9999.ebuild b/app-emulation/wine-staging/wine-staging-9999.ebuild
index bf30ea0d2af9..beaa12265098 100644
--- a/app-emulation/wine-staging/wine-staging-9999.ebuild
+++ b/app-emulation/wine-staging/wine-staging-9999.ebuild
@@ -41,6 +41,7 @@ IUSE="
+truetype udev udisks +unwind usb v4l +vulkan wayland wow64
+xcomposite xinerama"
# bug #551124 for truetype
+# TODO: wow64 can be done without mingw if using clang (needs bug #912237)
REQUIRED_USE="
X? ( truetype )
crossdev-mingw? ( mingw )
@@ -233,7 +234,7 @@ src_prepare() {
# drop as a quick fix for now which hopefully should be safe
sed -i '/MSVCRTFLAGS=/s/-mabi=ms//' configure.ac || die
else
- # ./configure will abort looking for -mabi=ms, so do it early
+ # known broken due to bug #912237, require mingw for now
die "building ${PN} with clang requires USE=mingw to be enabled"
fi
fi