summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-11-23 12:26:50 -0500
committerIonen Wolkens <ionen@gentoo.org>2022-11-23 15:38:21 -0500
commitbbe6f606d4b0bb181c537d1008da601268b3f596 (patch)
treec75be4dc552fcbf19c58865b70f33f447c4575fe /app-emulation/wine-proton
parentapp-emulation/wine-staging: migrate to eselect-wine-2 (diff)
downloadgentoo-bbe6f606d4b0bb181c537d1008da601268b3f596.tar.gz
gentoo-bbe6f606d4b0bb181c537d1008da601268b3f596.tar.bz2
gentoo-bbe6f606d4b0bb181c537d1008da601268b3f596.zip
app-emulation/wine-proton: migrate to eselect-wine-2
While >=eselect-wine-2 does not need ebuild modifications to work thanks to compat code, downgrading it does not work nicely given Wine slots won't be "registered" anymore (requires doing it manually, or re-emerging wine). So cleanup now and force IDEPEND on newer to help prevent mishaps. The replace check, nonfatal, registering, etc... is no longer necessary. prerm -> postrm is intended, prerm still works but relies on hacks to do so and should be avoided. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-emulation/wine-proton')
-rw-r--r--app-emulation/wine-proton/wine-proton-7.0.4.ebuild21
-rw-r--r--app-emulation/wine-proton/wine-proton-7.0.9999.ebuild21
2 files changed, 10 insertions, 32 deletions
diff --git a/app-emulation/wine-proton/wine-proton-7.0.4.ebuild b/app-emulation/wine-proton/wine-proton-7.0.4.ebuild
index dcb70f280da0..bf0f5280395f 100644
--- a/app-emulation/wine-proton/wine-proton-7.0.4.ebuild
+++ b/app-emulation/wine-proton/wine-proton-7.0.4.ebuild
@@ -101,7 +101,7 @@ BDEPEND="
virtual/pkgconfig
nls? ( sys-devel/gettext )
!crossdev-mingw? ( dev-util/mingw64-toolchain[${MULTILIB_USEDEP}] )"
-IDEPEND=">=app-eselect/eselect-wine-1.2.2-r1"
+IDEPEND=">=app-eselect/eselect-wine-2"
QA_TEXTRELS="usr/lib/*/wine/i386-unix/*.so" # uses -fno-PIC -Wl,-z,notext
@@ -299,27 +299,16 @@ src_install() {
readme.gentoo_create_doc
}
-wine-eselect() {
- ebegin "${1^}ing ${P} using eselect-wine"
- eselect wine ${1} ${P} &&
- eselect wine ${1} --${PN#wine-} ${P} &&
- eselect wine update --if-unset &&
- eselect wine update --${PN#wine-} --if-unset
- eend ${?} || die -n "eselect failed, may need to manually handle ${P}"
-}
-
pkg_preinst() {
has_version ${CATEGORY}/${PN} && WINE_HAD_ANY_SLOT=
}
pkg_postinst() {
- wine-eselect register
-
[[ -v WINE_HAD_ANY_SLOT ]] || readme.gentoo_print_elog
+
+ eselect wine update --if-unset || die
}
-pkg_prerm() {
- if [[ ${REPLACED_BY_VERSION%-r*} != ${PV} ]]; then #881035
- nonfatal wine-eselect deregister
- fi
+pkg_postrm() {
+ eselect wine update --if-unset || die
}
diff --git a/app-emulation/wine-proton/wine-proton-7.0.9999.ebuild b/app-emulation/wine-proton/wine-proton-7.0.9999.ebuild
index 6206f63f753b..934259b7c815 100644
--- a/app-emulation/wine-proton/wine-proton-7.0.9999.ebuild
+++ b/app-emulation/wine-proton/wine-proton-7.0.9999.ebuild
@@ -101,7 +101,7 @@ BDEPEND="
virtual/pkgconfig
nls? ( sys-devel/gettext )
!crossdev-mingw? ( dev-util/mingw64-toolchain[${MULTILIB_USEDEP}] )"
-IDEPEND=">=app-eselect/eselect-wine-1.2.2-r1"
+IDEPEND=">=app-eselect/eselect-wine-2"
QA_TEXTRELS="usr/lib/*/wine/i386-unix/*.so" # uses -fno-PIC -Wl,-z,notext
@@ -299,27 +299,16 @@ src_install() {
readme.gentoo_create_doc
}
-wine-eselect() {
- ebegin "${1^}ing ${P} using eselect-wine"
- eselect wine ${1} ${P} &&
- eselect wine ${1} --${PN#wine-} ${P} &&
- eselect wine update --if-unset &&
- eselect wine update --${PN#wine-} --if-unset
- eend ${?} || die -n "eselect failed, may need to manually handle ${P}"
-}
-
pkg_preinst() {
has_version ${CATEGORY}/${PN} && WINE_HAD_ANY_SLOT=
}
pkg_postinst() {
- wine-eselect register
-
[[ -v WINE_HAD_ANY_SLOT ]] || readme.gentoo_print_elog
+
+ eselect wine update --if-unset || die
}
-pkg_prerm() {
- if [[ ${REPLACED_BY_VERSION%-r*} != ${PV} ]]; then #881035
- nonfatal wine-eselect deregister
- fi
+pkg_postrm() {
+ eselect wine update --if-unset || die
}