summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Sarnie <sarnex@gentoo.org>2022-04-09 10:58:18 -0400
committerNick Sarnie <sarnex@gentoo.org>2022-04-09 11:00:34 -0400
commit8cd06d6df2d0e74055987eb28bc8e17d9b16b4a7 (patch)
tree7ebe531d0db758f278e7edfe757cb54b23d0bf77 /app-emulation/wine-mono
parentdev-python/zope-configuration: Sync python_test with zope-interface (diff)
downloadgentoo-8cd06d6df2d0e74055987eb28bc8e17d9b16b4a7.tar.gz
gentoo-8cd06d6df2d0e74055987eb28bc8e17d9b16b4a7.tar.bz2
gentoo-8cd06d6df2d0e74055987eb28bc8e17d9b16b4a7.zip
app-emulation/wine-mono: Sync with ::wine
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Nick Sarnie <sarnex@gentoo.org>
Diffstat (limited to 'app-emulation/wine-mono')
-rw-r--r--app-emulation/wine-mono/Manifest2
-rw-r--r--app-emulation/wine-mono/wine-mono-7.2.0.ebuild29
2 files changed, 31 insertions, 0 deletions
diff --git a/app-emulation/wine-mono/Manifest b/app-emulation/wine-mono/Manifest
index eac43913bd18..0bea0023c2cd 100644
--- a/app-emulation/wine-mono/Manifest
+++ b/app-emulation/wine-mono/Manifest
@@ -6,3 +6,5 @@ DIST wine-mono-7.0.0-x86.msi 86433280 BLAKE2B 9d164bf10f9c790a1f518624321a779658
DIST wine-mono-7.0.0-x86.tar.xz 45085800 BLAKE2B 504c57acce486c19a54bf33cdb4b9444c07a58a7f56ced0c93178886a91fa5d94a61f6e26aa885f3e3a2cceb2ff792f01006a4b16fa5bb88c3d25ddff02fefd7 SHA512 a3977563c5eb6418eaeda25e5b39bd2ef1faf305d514979211e049280c4577718ca48c8566e527b97a58fc465b310dd600093a616102573e12e8985794d828a6
DIST wine-mono-7.1.1-x86.msi 86606336 BLAKE2B 817d02bc090e5f324519a118de53a51510f601e86b84f93e06762ac583038cf96ce3f2cdd107c838261bc5f93cd336c1c0f18ac414626b98bbe4f35ad2749e04 SHA512 5a9a01d129c095d2fe8301073fefee7dca8cc26b9fc72c9ea88c00cbaacd1a40e2defb163152448c3de94ebe7cff46aa81f92ccf09fcaf084a7a18805fa03294
DIST wine-mono-7.1.1-x86.tar.xz 45220396 BLAKE2B 8a4cfa9496a51adb884c9062162413564cb939624ec551e97467eed41efc6e67e6296b2b0924eaa9565e98ea5595e140db691f23ef28edbf16456e3f6d39bd05 SHA512 b52f8a71900a34c687fd86559db16f2b7a3abe0f3965b5050e1859646c7bb00e070cc394f9a175995ccb50501d15844853b49931a7ac7cd2022581e241f31924
+DIST wine-mono-7.2.0-x86.msi 86910464 BLAKE2B 4e07c88202b85141faa5fe66e8254839f9d048922fcae6f71468273c1443c148f32746f0cc58b8c16f4f5c46678076072ae5a443e090371ad863387f4c5f15f0 SHA512 855a829a247de1e6ee31e07d06cc9d23b3011f43937c13a04f992fbc99080c32cd2dfc44e07bbdf6a71935b75192dd0648288c622eae00b3226e3c58ff55d826
+DIST wine-mono-7.2.0-x86.tar.xz 42477712 BLAKE2B f82e5b16b7f6554d919fa082eaa1686a22b798b1cf377aaa6b29f67682749a6e851cd3ee4d52a227c8d279442ed018704a92e3917593de70e588b47a7635395b SHA512 791c93425f37dfb7d481f0afb1b15bd18b084a764d70d2bf211fe791c94c44673940177870dae898e6b0adf3bf08f01f0ecb2fc1c5783c96f4ed4cede8fdb34d
diff --git a/app-emulation/wine-mono/wine-mono-7.2.0.ebuild b/app-emulation/wine-mono/wine-mono-7.2.0.ebuild
new file mode 100644
index 000000000000..0836b039a90f
--- /dev/null
+++ b/app-emulation/wine-mono/wine-mono-7.2.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Wine Mono is a replacement for the .NET runtime and class libraries in Wine"
+HOMEPAGE="https://www.winehq.org/"
+SRC_URI="
+ !shared? ( https://dl.winehq.org/wine/${PN}/${PV}/${P}-x86.msi )
+ shared? ( https://dl.winehq.org/wine/${PN}/${PV}/${P}-x86.tar.xz )
+"
+
+LICENSE="BSD-2 GPL-2 LGPL-2.1 MIT MPL-1.1"
+SLOT="${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+shared"
+
+DEPEND="!!app-emulation/wine:0"
+
+S="${WORKDIR}"
+
+src_install() {
+ insinto /usr/share/wine/mono
+ if use shared; then
+ doins -r "${P}"
+ else
+ doins "${DISTDIR}/${P}-x86.msi"
+ fi
+}