summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-06-08 08:51:30 +0000
committerSam James <sam@gentoo.org>2021-06-08 08:51:30 +0000
commit1328f5ce8c0fed6c3a374a7bc2a13c54ddf89893 (patch)
treef9b9b522b6d7d09f5782af2105adacaa5636b0e6 /app-emulation/libguestfs
parentsys-kernel/gentoo-kernel: add hardened useflag/config (diff)
downloadgentoo-1328f5ce8c0fed6c3a374a7bc2a13c54ddf89893.tar.gz
gentoo-1328f5ce8c0fed6c3a374a7bc2a13c54ddf89893.tar.bz2
gentoo-1328f5ce8c0fed6c3a374a7bc2a13c54ddf89893.zip
app-emulation/libguestfs: don't call AR directly
Closes: https://bugs.gentoo.org/794877 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-emulation/libguestfs')
-rw-r--r--app-emulation/libguestfs/libguestfs-1.44.1.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/app-emulation/libguestfs/libguestfs-1.44.1.ebuild b/app-emulation/libguestfs/libguestfs-1.44.1.ebuild
index 57aa2f01a447..3678f17814d1 100644
--- a/app-emulation/libguestfs/libguestfs-1.44.1.ebuild
+++ b/app-emulation/libguestfs/libguestfs-1.44.1.ebuild
@@ -6,7 +6,7 @@ EAPI=7
LUA_COMPAT=( lua5-1 )
PYTHON_COMPAT=( python3_{7,8,9} )
-inherit autotools bash-completion-r1 l10n linux-info lua-single perl-functions python-single-r1 xdg-utils flag-o-matic
+inherit autotools bash-completion-r1 l10n linux-info lua-single perl-functions python-single-r1 toolchain-funcs xdg-utils flag-o-matic
MY_PV_1="$(ver_cut 1-2)"
MY_PV_2="$(ver_cut 2)"
@@ -136,6 +136,9 @@ src_prepare() {
}
src_configure() {
+ # bug #794877
+ tc-export AR
+
# Disable feature test for kvm for more reason
# i.e: not loaded module in __build__ time,
# build server not supported kvm, etc. ...