summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2021-11-18 02:55:40 -0500
committerMike Frysinger <vapier@gentoo.org>2021-11-18 02:59:47 -0500
commit0fa2a867cc1298a4c0cd3babab783072d2f6e102 (patch)
treee0c732c4187d3a8a0911887539516fb00293821e /app-emulation/hercules
parentapp-emulation/hercules: fix ./libtool not fond warnings #791859 (diff)
downloadgentoo-0fa2a867cc1298a4c0cd3babab783072d2f6e102.tar.gz
gentoo-0fa2a867cc1298a4c0cd3babab783072d2f6e102.tar.bz2
gentoo-0fa2a867cc1298a4c0cd3babab783072d2f6e102.zip
app-emulation/hercules: do not delete libtool module .la files #720342
Since hercules uses libltdl to load its internal modules, we need to leave the .la files in place for it to process. Also add subslot linkage to these libs while we're updating. Bug: https://bugs.gentoo.org/252716 Closes: https://bugs.gentoo.org/720342 Signed-off-by: Mike Frysinger <vapier@gentoo.org>
Diffstat (limited to 'app-emulation/hercules')
-rw-r--r--app-emulation/hercules/hercules-3.13-r1.ebuild (renamed from app-emulation/hercules/hercules-3.13.ebuild)12
1 files changed, 6 insertions, 6 deletions
diff --git a/app-emulation/hercules/hercules-3.13.ebuild b/app-emulation/hercules/hercules-3.13-r1.ebuild
index e128b5c5332e..f068c94f7e2f 100644
--- a/app-emulation/hercules/hercules-3.13.ebuild
+++ b/app-emulation/hercules/hercules-3.13-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI="7"
inherit autotools flag-o-matic
@@ -15,10 +15,10 @@ KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~x64-macos"
IUSE="bzip2 custom-cflags +suid"
RDEPEND="
- dev-libs/libltdl
+ dev-libs/libltdl:=
net-libs/libnsl:0=
- sys-libs/zlib
- bzip2? ( app-arch/bzip2 )"
+ sys-libs/zlib:=
+ bzip2? ( app-arch/bzip2:= )"
DEPEND="${RDEPEND}"
PATCHES=(
@@ -61,6 +61,6 @@ src_install() {
insinto /usr/share/hercules
doins hercules.cnf
- # no static archives
- find "${D}" -name '*.la' -delete || die
+ # No static archives. Have to leave .la files for modules. #720342
+ rm "${ED}/usr/$(get_libdir)/"*.la || die
}