summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Ziak <0xe2.0x9a.0x9b@gmail.com>2020-09-20 15:51:26 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-10-10 10:22:33 +0300
commit03e710ad54f820ad9491e7e7255a56aed30cfaeb (patch)
tree53e2bba94bcb60e43a4ac400fe79ce2046de5c1a /app-emulation/fuse
parentapp-emulation/fuse: fix building with GCC 10 (diff)
downloadgentoo-03e710ad54f820ad9491e7e7255a56aed30cfaeb.tar.gz
gentoo-03e710ad54f820ad9491e7e7255a56aed30cfaeb.tar.bz2
gentoo-03e710ad54f820ad9491e7e7255a56aed30cfaeb.zip
app-emulation/fuse: use libjsw if not using SDL
Closes: https://bugs.gentoo.org/743394 Signed-off-by: Jan Ziak <0xe2.0x9a.0x9b@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/17615 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-emulation/fuse')
-rw-r--r--app-emulation/fuse/fuse-1.5.7.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/app-emulation/fuse/fuse-1.5.7.ebuild b/app-emulation/fuse/fuse-1.5.7.ebuild
index b75ae1134c58..063ecf27471a 100644
--- a/app-emulation/fuse/fuse-1.5.7.ebuild
+++ b/app-emulation/fuse/fuse-1.5.7.ebuild
@@ -27,7 +27,7 @@ RDEPEND="
backend-X? ( x11-libs/libX11 x11-libs/libXext )
!backend-fbcon? ( !backend-sdl? ( !backend-svga? ( !backend-X? ( x11-libs/gtk+:3 ) ) ) )
gpm? ( sys-libs/gpm )
- joystick? ( media-libs/libjsw )
+ joystick? ( !backend-sdl? ( media-libs/libjsw ) )
png? ( media-libs/libpng:0= sys-libs/zlib )
xml? ( dev-libs/libxml2:2 )"
DEPEND="${RDEPEND}
@@ -54,7 +54,6 @@ src_configure() {
$(use_with ao libao)
$(use_with gpm)
$(use_with joystick)
- $(use_enable joystick ui-joystick)
$(use_enable memlimit smallmem)
$(use_with png)
$(use_with xml libxml2)
@@ -72,6 +71,8 @@ src_configure() {
myconf+=("--with-gtk")
fi
+ use joystick && myconf+=( $(use_enable backend-sdl ui-joystick) )
+
econf "${myconf[@]}"
}