summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-08-21 12:13:33 +0200
committerManuel Rüger <mrueg@gentoo.org>2017-08-21 12:13:33 +0200
commit8e4949baebc855d866ab5d633e64632e1b40d63a (patch)
treee535f9ec6b4f1d61716ba2eab33e78519be05593 /app-emulation/containerd/containerd-0.2.9_p20170605.ebuild
parentapp-emulation/docker-runc: Update snapshot (diff)
downloadgentoo-8e4949baebc855d866ab5d633e64632e1b40d63a.tar.gz
gentoo-8e4949baebc855d866ab5d633e64632e1b40d63a.tar.bz2
gentoo-8e4949baebc855d866ab5d633e64632e1b40d63a.zip
app-emulation/containerd: Update snapshot
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'app-emulation/containerd/containerd-0.2.9_p20170605.ebuild')
-rw-r--r--app-emulation/containerd/containerd-0.2.9_p20170605.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-emulation/containerd/containerd-0.2.9_p20170605.ebuild b/app-emulation/containerd/containerd-0.2.9_p20170605.ebuild
new file mode 100644
index 000000000000..70e979be3fa9
--- /dev/null
+++ b/app-emulation/containerd/containerd-0.2.9_p20170605.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+EGO_PN="github.com/${PN}/${PN}"
+
+inherit toolchain-funcs
+
+if [[ ${PV} == *9999 ]]; then
+ inherit golang-vcs
+else
+ MY_PV="${PV/_/-}"
+ EGIT_COMMIT="6e23458c129b551d5c9871e5174f6b1b7f6d1170"
+ SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~ppc64"
+ inherit golang-vcs-snapshot
+fi
+
+DESCRIPTION="A daemon to control runC"
+HOMEPAGE="https://containerd.tools"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="hardened +seccomp"
+
+DEPEND=""
+RDEPEND=">=app-emulation/docker-runc-1.0.0_rc3_p20170706
+ seccomp? ( sys-libs/libseccomp )"
+
+S=${WORKDIR}/${P}/src/${EGO_PN}
+
+RESTRICT="test"
+
+src_compile() {
+ local options=( $(usex seccomp "seccomp" '') )
+ export GOPATH="${WORKDIR}/${P}" # ${PWD}/vendor
+ LDFLAGS=$(usex hardened '-extldflags -fno-PIC' '') emake GIT_COMMIT="$EGIT_COMMIT" BUILDTAGS="${options[@]}"
+}
+
+src_install() {
+ dobin bin/containerd* bin/ctr
+}