summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-10-06 20:13:32 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-10-06 21:51:28 +0200
commitee10a6c0e8e0cc8cfe1af5a786b32c87df08a2af (patch)
tree8cc040c17defb4e2e79019307375f2043f9c7176 /app-emacs
parentapp-emacs/commander: minor tweaks (diff)
downloadgentoo-ee10a6c0e8e0cc8cfe1af5a786b32c87df08a2af.tar.gz
gentoo-ee10a6c0e8e0cc8cfe1af5a786b32c87df08a2af.tar.bz2
gentoo-ee10a6c0e8e0cc8cfe1af5a786b32c87df08a2af.zip
app-emacs/parsebib: minor tweaks
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/parsebib/parsebib-4.3.ebuild24
1 files changed, 13 insertions, 11 deletions
diff --git a/app-emacs/parsebib/parsebib-4.3.ebuild b/app-emacs/parsebib/parsebib-4.3.ebuild
index 86b48a11e4ab..eccdb4d8583f 100644
--- a/app-emacs/parsebib/parsebib-4.3.ebuild
+++ b/app-emacs/parsebib/parsebib-4.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -7,20 +7,22 @@ inherit elisp
DESCRIPTION="Emacs Lisp library for reading .bib files"
HOMEPAGE="https://github.com/joostkremers/parsebib/"
-SRC_URI="https://github.com/joostkremers/${PN}/archive/${PV}.tar.gz
- -> ${P}.tar.gz"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/joostkremers/${PN}.git"
+else
+ SRC_URI="https://github.com/joostkremers/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="amd64 ~x86"
+fi
LICENSE="BSD"
-KEYWORDS="amd64 ~x86"
SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-BDEPEND="test? ( app-emacs/ert-runner )"
DOCS=( README.md )
SITEFILE="50${PN}-gentoo.el"
-src_test() {
- ert-runner -L . -L test --reporter ert+duration --script test || die
-}
+elisp-enable-tests ert-runner test