summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-11-02 22:41:02 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-11-02 23:11:22 +0100
commit9600a421254ef4c2cde543d430903df56b9a0ddb (patch)
tree385e747d39329e0a23dc56c65a95f0e96a91bb06 /app-emacs
parentdev-ml/yojson: bump to 2.1.1 (diff)
downloadgentoo-9600a421254ef4c2cde543d430903df56b9a0ddb.tar.gz
gentoo-9600a421254ef4c2cde543d430903df56b9a0ddb.tar.bz2
gentoo-9600a421254ef4c2cde543d430903df56b9a0ddb.zip
app-emacs/git-modes: bump to 1.4.2
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/git-modes/Manifest1
-rw-r--r--app-emacs/git-modes/git-modes-1.4.2.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/app-emacs/git-modes/Manifest b/app-emacs/git-modes/Manifest
index 77c01c50dafc..5a7c733f1bd7 100644
--- a/app-emacs/git-modes/Manifest
+++ b/app-emacs/git-modes/Manifest
@@ -1 +1,2 @@
DIST git-modes-1.4.1.tar.gz 18445 BLAKE2B 99353090333aae538fc5daa7c8e127ac58b518c03e871d7f397b716110fcbbd45d553e4e67ad6dfe8c874054c471fc0e018e890e6c0487eea4d1559de54e4e71 SHA512 374b2ea09af62a3b30084206e51f05989c6fd8e7e2435253e4d676f4ea3ec020d56681e2bd41db75a395ad677e5686744ca7e425a7a33eaa7d4d0a1a3d337d41
+DIST git-modes-1.4.2.tar.gz 18444 BLAKE2B ecb8894b41ba9f7744a4ceceedea339fca9993bf3b3335c93fd408ad05a7136266ea84cf28891684e0932bf8f1b997f9cb32c4ca7b4f44f735e6c45885f8f012 SHA512 b968b6bab869ad7d8b7232d2a97ab903c30c6fdf8fe0705633f0a7010900d5224f6ea2174708b4ef816241f2a6527bd7eb4f891c2072aee58aea1a153a825d9f
diff --git a/app-emacs/git-modes/git-modes-1.4.2.ebuild b/app-emacs/git-modes/git-modes-1.4.2.ebuild
new file mode 100644
index 000000000000..75f248bff469
--- /dev/null
+++ b/app-emacs/git-modes/git-modes-1.4.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Emacs major modes for editing Git configuration files"
+HOMEPAGE="https://github.com/magit/git-modes/"
+SRC_URI="https://github.com/magit/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+
+RDEPEND=">=app-emacs/compat-29.1.4.1"
+BDEPEND="${RDEPEND}"
+
+DOCS=( README.org )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+
+ elisp-make-autoload-file
+}