summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-10-06 20:58:20 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-10-06 21:51:34 +0200
commit58ab7166698ac11d85524a9f28b48a13f072d774 (patch)
tree84018d77b4992bba4ce689fa198052f771f91f36 /app-emacs
parentapp-emacs/epc: minor tweaks (diff)
downloadgentoo-58ab7166698ac11d85524a9f28b48a13f072d774.tar.gz
gentoo-58ab7166698ac11d85524a9f28b48a13f072d774.tar.bz2
gentoo-58ab7166698ac11d85524a9f28b48a13f072d774.zip
app-emacs/shut-up: minor tweaks
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/shut-up/shut-up-0.3.3.ebuild20
1 files changed, 13 insertions, 7 deletions
diff --git a/app-emacs/shut-up/shut-up-0.3.3.ebuild b/app-emacs/shut-up/shut-up-0.3.3.ebuild
index 2ec39fef42d5..6765c6368ed6 100644
--- a/app-emacs/shut-up/shut-up-0.3.3.ebuild
+++ b/app-emacs/shut-up/shut-up-0.3.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -7,11 +7,20 @@ inherit elisp
DESCRIPTION="Reduce Emacs output of messages"
HOMEPAGE="https://github.com/cask/shut-up/"
-SRC_URI="https://github.com/cask/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/cask/${PN}.git"
+else
+ SRC_URI="https://github.com/cask/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~alpha amd64 ~arm arm64 ~ppc64 ~riscv ~sparc ~x86"
+fi
LICENSE="GPL-3+"
SLOT="0"
-KEYWORDS="~alpha amd64 ~arm arm64 ~ppc64 ~riscv ~sparc ~x86"
IUSE="test"
RESTRICT="!test? ( test )"
@@ -25,7 +34,4 @@ BDEPEND="
DOCS=( README.md )
SITEFILE="50${PN}-gentoo.el"
-src_test() {
- ${EMACS} ${EMACSFLAGS} -L . -L test -l test/${PN}-test.el \
- -f ert-run-tests-batch-and-exit || die "tests failed"
-}
+elisp-enable-tests ert test