summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-10-13 20:59:48 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-10-13 21:23:14 +0200
commit1027a8e560579c63e45dcd24ecedf18150cd5071 (patch)
tree49f948d85ac882bb1e0bfd5145ff35083cef5fa6 /app-emacs
parentdev-lang/nim: use the makefile for initial compilation (diff)
downloadgentoo-1027a8e560579c63e45dcd24ecedf18150cd5071.tar.gz
gentoo-1027a8e560579c63e45dcd24ecedf18150cd5071.tar.bz2
gentoo-1027a8e560579c63e45dcd24ecedf18150cd5071.zip
app-emacs/gptel: bump to 0.9.5
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/gptel/Manifest1
-rw-r--r--app-emacs/gptel/gptel-0.9.5.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/app-emacs/gptel/Manifest b/app-emacs/gptel/Manifest
index 0ccb968c75de..ccce4365f5fc 100644
--- a/app-emacs/gptel/Manifest
+++ b/app-emacs/gptel/Manifest
@@ -1 +1,2 @@
DIST gptel-0.9.0.tar.gz 75974 BLAKE2B 51bf6ebe754a8fecaa2645d9dba77b844dbc65fbfd430ff67dcaa6b4893c66960f83c8e4344d0fa8b294ba8b468c8ce744fa0f284ed4e87b6e694edb07d2dd14 SHA512 6b7030bc87ef5a9edac547efe62c3392cbca08973eec5f7ace4358b0ad8c25049b69309beec100e6604ed35935468f531f0e0325df65d771819f80826b6b419d
+DIST gptel-0.9.5.tar.gz 89369 BLAKE2B 7556163a95484400f9a24bbdced5e8e72f7f18833acd20a8085b3e0681a5f66a391d492f41d606bf762f0375c641923b822bfef49f70d9f64a384db3cc888a52 SHA512 98377cc3c05eacfc61b1f47a087c92a926cb1881b8194e856adb5613fdc0c3abc0274d927b3fcc8e8a910af93a007c994cc37630c1f85e67fdd579866a29f9a8
diff --git a/app-emacs/gptel/gptel-0.9.5.ebuild b/app-emacs/gptel/gptel-0.9.5.ebuild
new file mode 100644
index 000000000000..783dad3ec302
--- /dev/null
+++ b/app-emacs/gptel/gptel-0.9.5.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS="27.1"
+
+inherit elisp
+
+DESCRIPTION="Simple Large Language Model chat client for GNU Emacs"
+HOMEPAGE="https://github.com/karthink/gptel/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/karthink/${PN}.git"
+else
+ SRC_URI="https://github.com/karthink/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~arm64"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+RDEPEND="
+ >=app-emacs/compat-30.0.0.0
+ app-emacs/transient
+"
+BDEPEND="
+ ${RDEPEND}
+"
+
+DOCS=( README.org )
+SITEFILE="50${PN}-gentoo.el"
+
+elisp-enable-tests ert test -l gptel-org -l gptel-org-test
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}