summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2021-07-31 14:34:00 +0200
committerUlrich Müller <ulm@gentoo.org>2021-07-31 14:36:22 +0200
commitba7b046343e74e8f444f7d8bdc9b255d690bc94d (patch)
treed928ea35fe3821e8e58a289c87e4116ddba39719 /app-emacs/vterm
parentapp-emacs/vterm: Use versioned filename for patch (diff)
downloadgentoo-ba7b046343e74e8f444f7d8bdc9b255d690bc94d.tar.gz
gentoo-ba7b046343e74e8f444f7d8bdc9b255d690bc94d.tar.bz2
gentoo-ba7b046343e74e8f444f7d8bdc9b255d690bc94d.zip
app-emacs/vterm: Version bump to 0.0.1_pre20210618
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-emacs/vterm')
-rw-r--r--app-emacs/vterm/Manifest1
-rw-r--r--app-emacs/vterm/files/vterm-0.0.1_pre20210618-dont-compile.patch22
-rw-r--r--app-emacs/vterm/vterm-0.0.1_pre20210618.ebuild45
3 files changed, 68 insertions, 0 deletions
diff --git a/app-emacs/vterm/Manifest b/app-emacs/vterm/Manifest
index f04e9cddcdd8..5294b04ce525 100644
--- a/app-emacs/vterm/Manifest
+++ b/app-emacs/vterm/Manifest
@@ -1 +1,2 @@
DIST vterm-0.0.1_pre20200713.tar.gz 48160 BLAKE2B 96c45ddb139d19f3020d7a8eebc1ee31a7dc098f47c16cfffc7bf3327261a4366763744a8158d3c8a066ec94be4966a5ef78804db95c9025eee06fb8c9e4aa76 SHA512 17726ad0957daeab2a87b398bfa24dbe3c4c48dfba932138a71cd8c992bf20bd2925a7118a89247bbd674dbecd7fda8663c564a278168bb207034efb03e50cd0
+DIST vterm-0.0.1_pre20210618.tar.gz 58389 BLAKE2B 71221d470e01d647093e3a3af0c57b416ef23e81ff4d783d032613e19f1d467752fea0d242ea0f72092e3cdabbdb88ba15a840d9e4116cf5aa95d54a020efe0d SHA512 9e23eff1c9c5d2cc8e970bb4d9910b3e0258987d09b765ece188641ff5e2696e30d59a409f45253f243162b8e71c0ea301049ff37c93ffec1e1c25206ca9c5d2
diff --git a/app-emacs/vterm/files/vterm-0.0.1_pre20210618-dont-compile.patch b/app-emacs/vterm/files/vterm-0.0.1_pre20210618-dont-compile.patch
new file mode 100644
index 000000000000..512b9d941423
--- /dev/null
+++ b/app-emacs/vterm/files/vterm-0.0.1_pre20210618-dont-compile.patch
@@ -0,0 +1,22 @@
+Simply error out if the module is not found. Don't confuse the user
+with messages about compiling the module, which won't work outside of
+the package's source tree.
+
+--- a/vterm.el
++++ b/vterm.el
+@@ -130,14 +130,7 @@
+ (message "Compilation of `emacs-libvterm' module succeeded")
+ (error "Compilation of `emacs-libvterm' module failed!")))))
+
+-;; If the vterm-module is not compiled yet, compile it
+-(unless (require 'vterm-module nil t)
+- (if (or vterm-always-compile-module
+- (y-or-n-p "Vterm needs `vterm-module' to work. Compile it now? "))
+- (progn
+- (vterm-module-compile)
+- (require 'vterm-module))
+- (error "Vterm will not work until `vterm-module' is compiled!")))
++(require 'vterm-module)
+
+ ;;; Dependencies
+
diff --git a/app-emacs/vterm/vterm-0.0.1_pre20210618.ebuild b/app-emacs/vterm/vterm-0.0.1_pre20210618.ebuild
new file mode 100644
index 000000000000..77ce01cdc80f
--- /dev/null
+++ b/app-emacs/vterm/vterm-0.0.1_pre20210618.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+NEED_EMACS=26
+COMMIT="d9dfa624679afdd5db6ad25429ef86d3dd91401e"
+
+inherit cmake elisp
+
+MY_PN="emacs-libvterm"
+DESCRIPTION="Fully-featured terminal emulator based on libvterm"
+HOMEPAGE="https://github.com/akermu/emacs-libvterm"
+SRC_URI="https://github.com/akermu/${MY_PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+DEPEND="dev-libs/libvterm"
+RDEPEND="${DEPEND}
+ >=app-editors/emacs-26:*[dynamic-loading]"
+
+S="${WORKDIR}/${MY_PN}-${COMMIT}"
+PATCHES=("${FILESDIR}"/${PN}-0.0.1_pre20210618-dont-compile.patch)
+SITEFILE="50${PN}-gentoo.el"
+DOCS="README.md"
+
+src_prepare() {
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=("-DUSE_SYSTEM_LIBVTERM=ON")
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+ elisp_src_compile
+}
+
+src_install() {
+ elisp_src_install
+ elisp-modules-install ${PN} vterm-module.so
+}