summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2021-09-25 11:53:47 +0200
committerUlrich Müller <ulm@gentoo.org>2021-09-27 18:55:48 +0200
commiteca29d7f2950d5949fef42a05d9e003e467a48b0 (patch)
treee1f9e056733799a992e5b358047349ed664f03ab /app-emacs/vm
parentbzr.eclass: Drop support for EBZR_INITIAL_URI (diff)
downloadgentoo-eca29d7f2950d5949fef42a05d9e003e467a48b0.tar.gz
gentoo-eca29d7f2950d5949fef42a05d9e003e467a48b0.tar.bz2
gentoo-eca29d7f2950d5949fef42a05d9e003e467a48b0.zip
Revert "app-emacs/vm: remove -9999 ebuild due to ::gentoo not havgin bzr"
This reverts commit 1072d5e9992ac753dbcbfff6541f6a6f6f7fc913. Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-emacs/vm')
-rw-r--r--app-emacs/vm/vm-9999.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/app-emacs/vm/vm-9999.ebuild b/app-emacs/vm/vm-9999.ebuild
new file mode 100644
index 000000000000..7834ef8f589d
--- /dev/null
+++ b/app-emacs/vm/vm-9999.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit elisp bzr autotools
+
+DESCRIPTION="The VM mail reader for Emacs"
+HOMEPAGE="http://www.nongnu.org/viewmail/"
+EBZR_REPO_URI="lp:vm"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="bbdb ssl"
+
+BDEPEND="bbdb? ( app-emacs/bbdb )"
+RDEPEND="${BDEPEND}
+ ssl? ( net-misc/stunnel )"
+BDEPEND="${BDEPEND}
+ sys-apps/texinfo"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ eapply "${FILESDIR}"/vm-8.2.0_beta-texinfo-encoding.patch
+ if ! use bbdb; then
+ elog "Excluding vm-pcrisis.el since the \"bbdb\" USE flag is not set."
+ eapply "${FILESDIR}/${PN}-8.0-no-pcrisis.patch"
+ fi
+ eapply_user
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-emacs="emacs" \
+ --with-lispdir="${SITELISP}/${PN}" \
+ --with-etcdir="${SITEETC}/${PN}" \
+ --with-docdir="/usr/share/doc/${PF}" \
+ $(use bbdb && echo "--with-other-dirs=${SITELISP}/bbdb")
+}
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+
+ # delete duplicate documentation
+ find "${D}/${SITEETC}/${PN}" -type d -name pixmaps -prune \
+ -o -type f -exec rm '{}' '+' || die
+
+ dodoc example.vm
+ # NEWS is accessed from lisp and must not be compressed
+ docompress -x /usr/share/doc/${PF}/NEWS
+}