summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-08-26 17:29:38 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-08-26 17:46:10 +0200
commit7d0498921edf247868295d5b2c35f8a484e1af19 (patch)
tree2ed1c70f8c2611b81f351c38c1fc7b62613e3bb9 /app-emacs/transient
parentdev-lang/luau: bump to 0.592 (diff)
downloadgentoo-7d0498921edf247868295d5b2c35f8a484e1af19.tar.gz
gentoo-7d0498921edf247868295d5b2c35f8a484e1af19.tar.bz2
gentoo-7d0498921edf247868295d5b2c35f8a484e1af19.zip
app-emacs/transient: bump to 0.4.3
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/transient')
-rw-r--r--app-emacs/transient/Manifest1
-rw-r--r--app-emacs/transient/transient-0.4.3.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/app-emacs/transient/Manifest b/app-emacs/transient/Manifest
index 47beefd6005a..bc3b76690fa5 100644
--- a/app-emacs/transient/Manifest
+++ b/app-emacs/transient/Manifest
@@ -1 +1,2 @@
DIST transient-0.4.1.tar.gz 128614 BLAKE2B 407ae76f113e850dfc8235764a6b020c7cd94d6361bda3446024ec0bcc2f190f5b90e6d773350e7d84e5574a592503d097bf8e9cc3209c5993a1c2b37f9a442d SHA512 13e258818db5527f86ff02765e9b288a1944026255c660cfc151ba0c1ead22c6d36c6ec3d3129cff8ef62c2953288a6d588d595fa61d5972cfa465cc8248c64f
+DIST transient-0.4.3.tar.gz 129365 BLAKE2B d07fb5cb6586950bd3561b2a7f77b6458db58531e7735d203dabbfd292facaf44af850de4f4824f6335f41afcf79d03c0291d31af31b84b4118ffb8cae996f2a SHA512 afa2f75a0d4d6d45af1e36f155371dad6a966073cbab9a3858eec020458530d21a34860b88ec4d1e1e93570675b9df6d5692ed8f8a1903478ee5085c9d2d039a
diff --git a/app-emacs/transient/transient-0.4.3.ebuild b/app-emacs/transient/transient-0.4.3.ebuild
new file mode 100644
index 000000000000..8fae47219ad7
--- /dev/null
+++ b/app-emacs/transient/transient-0.4.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Transient commands abstraction for GNU Emacs"
+HOMEPAGE="https://magit.vc/manual/transient/
+ https://github.com/magit/transient/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/magit/${PN}.git"
+else
+ SRC_URI="https://github.com/magit/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DOCS=( CHANGELOG README.org docs/${PN}.org )
+ELISP_TEXINFO="docs/${PN}.texi"
+SITEFILE="50${PN}-gentoo.el"
+
+RDEPEND=">=app-emacs/compat-29.1.4.1"
+BDEPEND="
+ ${RDEPEND}
+ sys-apps/texinfo
+"
+
+src_prepare() {
+ mv lisp/*.el . || die
+
+ default
+}