summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emacs/scss-mode
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emacs/scss-mode')
-rw-r--r--app-emacs/scss-mode/Manifest2
-rw-r--r--app-emacs/scss-mode/files/50scss-mode-gentoo.el3
-rw-r--r--app-emacs/scss-mode/metadata.xml11
-rw-r--r--app-emacs/scss-mode/scss-mode-20130215.ebuild24
-rw-r--r--app-emacs/scss-mode/scss-mode-20150107.ebuild24
5 files changed, 64 insertions, 0 deletions
diff --git a/app-emacs/scss-mode/Manifest b/app-emacs/scss-mode/Manifest
new file mode 100644
index 000000000000..d5b122b69272
--- /dev/null
+++ b/app-emacs/scss-mode/Manifest
@@ -0,0 +1,2 @@
+DIST scss-mode-20130215-git.tar.gz 2632 SHA256 79c5360c7f3e76851d6aeb810d20d9ac66362f4420f967d9847338adb7df5f2a SHA512 2241d7e0c2689ba3997e4ffdf1ed167409c1d99a4f6a11911de39775a409d3299ba7e1bb2f7f0878b5b0d91e46706b65ef8e25cef83278894d8842af8bbc95be WHIRLPOOL 67792f4c20dc370e0dd078dc6212ddfd16030226a1fded057a69b514b984b79168e5a994d2126b32b9e17e4147a2597b16b5c1f788dbd378c71b45bd15772834
+DIST scss-mode-20150107-git.tar.gz 2718 SHA256 6f412eab87db85cdf3172d67c28841b0a0b910c473bf020c3babbb31ddd4ea2f SHA512 68a33d14166289af119625a5609c4dec47a05eb8c8452b42cf8e819368cc7561270c8223ac0624fee989f8c51592f456f91009c153fb857549d9c7e7c7e801a2 WHIRLPOOL 639653ccc9cdba87b7982a04ddd66236eaa4f2c8137839fdf35c5a015611fa01e160d790c9f698d0d1ac3e7033a29eb3f523554bff5ccdecaa8390dc3de13834
diff --git a/app-emacs/scss-mode/files/50scss-mode-gentoo.el b/app-emacs/scss-mode/files/50scss-mode-gentoo.el
new file mode 100644
index 000000000000..ac09f6c30786
--- /dev/null
+++ b/app-emacs/scss-mode/files/50scss-mode-gentoo.el
@@ -0,0 +1,3 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'scss-mode "scss-mode" "Simple mode to edit SCSS." t)
+(add-to-list 'auto-mode-alist '("\\.scss\\'" . scss-mode))
diff --git a/app-emacs/scss-mode/metadata.xml b/app-emacs/scss-mode/metadata.xml
new file mode 100644
index 000000000000..86027b0987d0
--- /dev/null
+++ b/app-emacs/scss-mode/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+<maintainer>
+ <email>flameeyes@gentoo.org</email>
+</maintainer>
+<upstream>
+ <remote-id type="github">antonj/scss-mode</remote-id>
+</upstream>
+</pkgmetadata>
diff --git a/app-emacs/scss-mode/scss-mode-20130215.ebuild b/app-emacs/scss-mode/scss-mode-20130215.ebuild
new file mode 100644
index 000000000000..87310e245ed5
--- /dev/null
+++ b/app-emacs/scss-mode/scss-mode-20130215.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit elisp
+
+GITHUB_SHA1=3452e92800c345690195f55a74ba4118c5c4d004
+
+DESCRIPTION="Major mode for editing SCSS files in Emacs"
+HOMEPAGE="https://github.com/antonj/scss-mode"
+SRC_URI="${HOMEPAGE}/archive/${GITHUB_SHA1}.tar.gz -> ${P}-git.tar.gz"
+S="${WORKDIR}/${PN}-${GITHUB_SHA1}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DOCS="README.org"
+SITEFILE="50${PN}-gentoo.el"
+
+DEPEND="dev-ruby/sass"
diff --git a/app-emacs/scss-mode/scss-mode-20150107.ebuild b/app-emacs/scss-mode/scss-mode-20150107.ebuild
new file mode 100644
index 000000000000..8332cedd1064
--- /dev/null
+++ b/app-emacs/scss-mode/scss-mode-20150107.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit elisp
+
+GITHUB_SHA1=b010d134f499c4b4ad33fe8a669a81e9a531b0b2
+
+DESCRIPTION="Major mode for editing SCSS files in Emacs"
+HOMEPAGE="https://github.com/antonj/scss-mode"
+SRC_URI="${HOMEPAGE}/archive/${GITHUB_SHA1}.tar.gz -> ${P}-git.tar.gz"
+S="${WORKDIR}/${PN}-${GITHUB_SHA1}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DOCS="README.org"
+SITEFILE="50${PN}-gentoo.el"
+
+DEPEND="dev-ruby/sass"