summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emacs/scheme-complete
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emacs/scheme-complete')
-rw-r--r--app-emacs/scheme-complete/Manifest2
-rw-r--r--app-emacs/scheme-complete/files/60scheme-complete-gentoo.el4
-rw-r--r--app-emacs/scheme-complete/metadata.xml9
-rw-r--r--app-emacs/scheme-complete/scheme-complete-0.8.10.ebuild18
-rw-r--r--app-emacs/scheme-complete/scheme-complete-0.8.11.ebuild17
5 files changed, 50 insertions, 0 deletions
diff --git a/app-emacs/scheme-complete/Manifest b/app-emacs/scheme-complete/Manifest
new file mode 100644
index 000000000000..3a09df9208be
--- /dev/null
+++ b/app-emacs/scheme-complete/Manifest
@@ -0,0 +1,2 @@
+DIST scheme-complete-0.8.10.el.gz 38713 SHA256 9af540763d75ba894ff3e84546cfea191f045f57a85ff9578bb5599c2a61950a SHA512 7058983a57f1fe3cbbc4066f62075b755bd8e9a83ce65bf26a3568889d05abc9972d4b7be57ac54867fc4abe5567e223c9640bd8c898dbc6422d449f41090956 WHIRLPOOL 073e880810c30e3f4fc9a3e0f2a9013597805f85c8e8e36450a9a49b3347ecc6be6c81756cb7fcf03c92601406253fe2b8b44434f4aed20decb04093007960b2
+DIST scheme-complete-0.8.11.el.gz 38847 SHA256 19663b5104044d84b1326d48b4ef8801da9b4da18bea3577dc52830b3a4233ce SHA512 90fe73dfee3377f19eca2107deb6c9d88260b2097358416dab5ad839dabc0a0678b7254ab6dbdc058cae2be5feeaa4cba2f66296e49060df5251c1888044fea8 WHIRLPOOL 6688e3a917fc2a6a400979203c5b8cf3e0f573849522822231e8a41acf91796d8b268e424266935a264db783e4bf659dd394d02c8a4b980179320c06729e4e2c
diff --git a/app-emacs/scheme-complete/files/60scheme-complete-gentoo.el b/app-emacs/scheme-complete/files/60scheme-complete-gentoo.el
new file mode 100644
index 000000000000..ab5aee4beaaf
--- /dev/null
+++ b/app-emacs/scheme-complete/files/60scheme-complete-gentoo.el
@@ -0,0 +1,4 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'scheme-smart-complete "scheme-complete" nil t)
+(autoload 'scheme-complete-or-indent "scheme-complete" nil t)
+(autoload 'scheme-get-current-symbol-info "scheme-complete")
diff --git a/app-emacs/scheme-complete/metadata.xml b/app-emacs/scheme-complete/metadata.xml
new file mode 100644
index 000000000000..51ab1920de63
--- /dev/null
+++ b/app-emacs/scheme-complete/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+<longdescription>
+ Very smart tab-completion and autodoc for Scheme code in Emacs, complete
+ with type inferencing and lexical environment awareness.
+</longdescription>
+</pkgmetadata>
diff --git a/app-emacs/scheme-complete/scheme-complete-0.8.10.ebuild b/app-emacs/scheme-complete/scheme-complete-0.8.10.ebuild
new file mode 100644
index 000000000000..359a12b8948c
--- /dev/null
+++ b/app-emacs/scheme-complete/scheme-complete-0.8.10.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit elisp
+
+DESCRIPTION="Scheme tab-completion and word-completion for Emacs"
+HOMEPAGE="http://synthcode.com/"
+SRC_URI="http://synthcode.com/emacs/${P}.el.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="alpha amd64 ppc ppc64 x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE=""
+
+SITEFILE="60${PN}-gentoo.el"
diff --git a/app-emacs/scheme-complete/scheme-complete-0.8.11.ebuild b/app-emacs/scheme-complete/scheme-complete-0.8.11.ebuild
new file mode 100644
index 000000000000..83d2235e6b62
--- /dev/null
+++ b/app-emacs/scheme-complete/scheme-complete-0.8.11.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="Scheme tab-completion and word-completion for Emacs"
+HOMEPAGE="http://synthcode.com/"
+SRC_URI="http://synthcode.com/emacs/${P}.el.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="alpha amd64 ppc ppc64 x86 ~amd64-linux ~x86-linux ~x86-macos"
+
+SITEFILE="60${PN}-gentoo.el"