summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2018-01-13 20:42:44 +0700
committerAndrey Grozin <grozin@gentoo.org>2018-01-13 20:42:44 +0700
commit68ca2875e96d925a1ad9486d859f10d92a177e76 (patch)
tree99c67f2c9a70abd5ebdabf3467755cbbe3cbd9c9 /app-emacs/pariemacs/pariemacs-3.14.ebuild
parentsci-mathematics/pari: bump to 2.9.4 (diff)
downloadgentoo-68ca2875e96d925a1ad9486d859f10d92a177e76.tar.gz
gentoo-68ca2875e96d925a1ad9486d859f10d92a177e76.tar.bz2
gentoo-68ca2875e96d925a1ad9486d859f10d92a177e76.zip
app-emacs/pariemacs: initial import
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'app-emacs/pariemacs/pariemacs-3.14.ebuild')
-rw-r--r--app-emacs/pariemacs/pariemacs-3.14.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-emacs/pariemacs/pariemacs-3.14.ebuild b/app-emacs/pariemacs/pariemacs-3.14.ebuild
new file mode 100644
index 000000000000..308e790bebef
--- /dev/null
+++ b/app-emacs/pariemacs/pariemacs-3.14.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit elisp
+
+DESCRIPTION="sci-mathematics/pari emacs mode"
+HOMEPAGE="http://iml.univ-mrs.fr/~ramare/ServeurPerso/GP-PARI/"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+SRC_URI="http://iml.univ-mrs.fr/~ramare/ServeurPerso/GP-PARI/latest-pari-distrib/${P}.tar.gz"
+
+RDEPEND="sci-mathematics/pari"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"
+SITEFILE="64${PN}-gentoo.el"
+DOCS="README CHANGES"
+
+src_prepare() {
+ eapply "${FILESDIR}"/${P}-makefile.patch
+ eapply_user
+ cp /usr/share/doc/pari-*/pari.cfg.bz2 . || die "pari.cfg.bz2 not found"
+ bunzip2 pari.cfg.bz2
+}
+
+src_compile() {
+ make pari-conf.el
+ make elc
+}