summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-04-19 18:31:26 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-04-19 18:34:21 +0200
commitb8036fc9fce9f0fc4f10834f85fd17fc3210d0e0 (patch)
treeed5ba8412bc17650ae78911ae2af70df410766ce /app-emacs/ecukes
parentapp-emacs/commander: new package; add version 0.7.0 (diff)
downloadgentoo-b8036fc9fce9f0fc4f10834f85fd17fc3210d0e0.tar.gz
gentoo-b8036fc9fce9f0fc4f10834f85fd17fc3210d0e0.tar.bz2
gentoo-b8036fc9fce9f0fc4f10834f85fd17fc3210d0e0.zip
app-emacs/ecukes: new package; add version 0.6.18
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/ecukes')
-rw-r--r--app-emacs/ecukes/Manifest1
-rw-r--r--app-emacs/ecukes/ecukes-0.6.18.ebuild66
-rw-r--r--app-emacs/ecukes/files/50ecukes-gentoo.el1
-rw-r--r--app-emacs/ecukes/files/ecukes-bin-launcher-fix.patch31
-rw-r--r--app-emacs/ecukes/metadata.xml13
5 files changed, 112 insertions, 0 deletions
diff --git a/app-emacs/ecukes/Manifest b/app-emacs/ecukes/Manifest
new file mode 100644
index 000000000000..a169e9c477be
--- /dev/null
+++ b/app-emacs/ecukes/Manifest
@@ -0,0 +1 @@
+DIST ecukes-0.6.18.tar.gz 85246 BLAKE2B f4469f155c0f2ce4756e429df2690b1dda3bb2f38f7e5847d14e1d21d0b8170535a2203fafe66649fc8416d41b983f6bc7428f6b4c053dcf0f9372f0973c0b15 SHA512 6d3a16b8dbf021026be5d7134166079bb1495ad4fd6b7e30386aad56c0196c46cbd3ee541ec8c24d5b7e1bb26e3c14fe5f9423b50341867c50b92194139eca02
diff --git a/app-emacs/ecukes/ecukes-0.6.18.ebuild b/app-emacs/ecukes/ecukes-0.6.18.ebuild
new file mode 100644
index 000000000000..26697cc08fe6
--- /dev/null
+++ b/app-emacs/ecukes/ecukes-0.6.18.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Cucumber for Emacs"
+HOMEPAGE="https://github.com/ecukes/ecukes/"
+SRC_URI="https://github.com/ecukes/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ app-emacs/ansi
+ app-emacs/commander
+ app-emacs/dash
+ app-emacs/espuds
+ app-emacs/f
+ app-emacs/s
+"
+BDEPEND="
+ ${RDEPEND}
+ test? ( app-emacs/el-mock )
+"
+
+DOCS=( README.markdown )
+PATCHES=( "${FILESDIR}"/${PN}-bin-launcher-fix.patch )
+
+# Remove pkg file and failing tests
+ELISP_REMOVE="${PN}-pkg.el test/${PN}-parse-line-test.el"
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ elisp_src_prepare
+
+ sed "s|@SITELISP@|${EPREFIX}${SITELISP}/${PN}|" -i bin/${PN} || die
+}
+
+src_compile() {
+ elisp_src_compile
+ elisp-compile reporters/*.el
+}
+
+src_test() {
+ local i
+ for i in test/ecukes-*-test.el ; do
+ ebegin "Running tests from ${i}"
+ ${EMACS} ${EMACSFLAGS} -L . -L test \
+ --eval "(require 'cl)" \
+ -l test/test-helper.el -l ${i} -l test/ecukes-test.el \
+ -f ert-run-tests-batch-and-exit
+ eend $? || die "tests failed, last ran tests from ${i}"
+ done
+}
+
+src_install() {
+ elisp_src_install
+ elisp-install ${PN}/reporters reporters/*.el{,c}
+
+ dobin bin/${PN}
+}
diff --git a/app-emacs/ecukes/files/50ecukes-gentoo.el b/app-emacs/ecukes/files/50ecukes-gentoo.el
new file mode 100644
index 000000000000..431f7e90ae73
--- /dev/null
+++ b/app-emacs/ecukes/files/50ecukes-gentoo.el
@@ -0,0 +1 @@
+(add-to-list 'load-path "@SITELISP@")
diff --git a/app-emacs/ecukes/files/ecukes-bin-launcher-fix.patch b/app-emacs/ecukes/files/ecukes-bin-launcher-fix.patch
new file mode 100644
index 000000000000..254fa28d09b3
--- /dev/null
+++ b/app-emacs/ecukes/files/ecukes-bin-launcher-fix.patch
@@ -0,0 +1,31 @@
+index 45ea622..b20754e 100755
+--- a/bin/ecukes
++++ b/bin/ecukes
+@@ -33,7 +33,7 @@
+ # Free Software Foundation, Inc., 51 Franklin Street, Fifth Floor,
+ # Boston, MA 02110-2022, USA.
+
+-ECUKES_HOME=$(dirname "$(dirname "$BASH_SOURCE")")
++ECUKES_HOME="@SITELISP@"
+ ECUKES_CLI=$ECUKES_HOME/ecukes-cli.el
+
+ if [[ -n "$INSIDE_EMACS" ]]; then
+@@ -60,9 +60,9 @@ if has_option "--win" $@ || has_option "--no-win" $@ ; then
+ export ECUKES_OUTFILE=$(mktemp /tmp/ecukes.XXX)
+
+ if has_option "--win" $@; then
+- "$ECUKES_EMACS" --load "$ECUKES_CLI" -Q
++ "$ECUKES_EMACS" --load "$ECUKES_CLI" -q
+ else
+- "$ECUKES_EMACS" -nw --load "$ECUKES_CLI" -Q
++ "$ECUKES_EMACS" -nw --load "$ECUKES_CLI" -q
+ fi
+
+ STATUS=$?
+@@ -72,5 +72,5 @@ if has_option "--win" $@ || has_option "--no-win" $@ ; then
+
+ exit $STATUS
+ else
+- "$ECUKES_EMACS" --script "$ECUKES_CLI" -Q
++ "$ECUKES_EMACS" --script "$ECUKES_CLI" -q
+ fi
diff --git a/app-emacs/ecukes/metadata.xml b/app-emacs/ecukes/metadata.xml
new file mode 100644
index 000000000000..b97306483f71
--- /dev/null
+++ b/app-emacs/ecukes/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/ecukes/ecukes/issues/</bugs-to>
+ <remote-id type="github">ecukes/ecukes</remote-id>
+ </upstream>
+</pkgmetadata>