summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2023-03-26 16:03:47 +0200
committerUlrich Müller <ulm@gentoo.org>2023-03-26 16:05:23 +0200
commitcc6c0df171f841c0dbd1ee980121779c0ba79e8e (patch)
treeb1d1548b64df89178ecc8c6b4abda71168a75560 /app-emacs/ebuild-mode
parentapp-office/libalkimia: Another cmake fix, this time from upstream (diff)
downloadgentoo-cc6c0df171f841c0dbd1ee980121779c0ba79e8e.tar.gz
gentoo-cc6c0df171f841c0dbd1ee980121779c0ba79e8e.tar.bz2
gentoo-cc6c0df171f841c0dbd1ee980121779c0ba79e8e.zip
app-emacs/ebuild-mode: add 1.63
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-emacs/ebuild-mode')
-rw-r--r--app-emacs/ebuild-mode/Manifest1
-rw-r--r--app-emacs/ebuild-mode/ebuild-mode-1.63.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/app-emacs/ebuild-mode/Manifest b/app-emacs/ebuild-mode/Manifest
index c4e9670ac7d0..fd1c0a9ca5e9 100644
--- a/app-emacs/ebuild-mode/Manifest
+++ b/app-emacs/ebuild-mode/Manifest
@@ -1,3 +1,4 @@
DIST ebuild-mode-1.60.tar.xz 36996 BLAKE2B a566c9f602ec6ac4126a4a13610e515faf2a02b8ca89f417a037a28f4b9ea633518d589d78f6deb54084be34cdc30c2a1896546b2f86c1166cedd47289edcfd8 SHA512 b04b37b7a376dc48a7f80ec0e60bf36a8b7ea92edcbdd45fbd002e80e8ea29111905a726177a869d607adffe78094efcdc94b1aad32afe1444a09b4e714dcecd
DIST ebuild-mode-1.61.tar.xz 38632 BLAKE2B f13f251918cf13533611c4d98a9aeceff10e9253c207a10c047c59952d6c8e50cdddb7c3ff65ed7b9565bd09fb45203c9cb57a277165b9cc7bbb47c5d8978a59 SHA512 a7087894299c3882ff0993a1a33cd192ebec078e7cea2f8964610d758a439350dcf36fe43aa43a42b89446d36b62a9b80bfce531e701b0183f3d69e56528ab62
DIST ebuild-mode-1.62.tar.xz 39080 BLAKE2B 91bb206f7ca3fecebc80d946d5840ce6e02610171d6179d360b188e270226e4f1dbe4ceddbc1e41f8e627c787b28454a20720d563bbabcffb3a99b7b10a1251d SHA512 9e7caafb45a7538dd66221d2a5dd9fef764c72f6f42db1ad1615e4017b7d4db14dcde09edfa0e8777a528af918e219521072040215d05a9c8a5cdc57ca395bd8
+DIST ebuild-mode-1.63.tar.xz 39600 BLAKE2B 1746e0ab558fd7b48dc778f2287b3a9f2b5f82f5e4e53e353b0b9c3de3436a8ec17f827d93cf1ff990dd780a33435ea946e19ac655fd0f39fee03beb07ce5509 SHA512 264678921d8a2e535fedcc06c9c0932a4898f3d33cc54d79107658d9a77048e00c5ec276d4c74dc55c2ba2c643024453542f16619fde473d417b446bbd78175c
diff --git a/app-emacs/ebuild-mode/ebuild-mode-1.63.ebuild b/app-emacs/ebuild-mode/ebuild-mode-1.63.ebuild
new file mode 100644
index 000000000000..7c4ed2c5c19a
--- /dev/null
+++ b/app-emacs/ebuild-mode/ebuild-mode-1.63.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp optfeature
+
+DESCRIPTION="Emacs modes for editing ebuilds and other Gentoo specific files"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Emacs"
+SRC_URI="https://dev.gentoo.org/~ulm/emacs/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+BDEPEND="sys-apps/texinfo"
+
+DOCS="ChangeLog keyword-generation.sh"
+ELISP_TEXINFO="${PN}.texi"
+SITEFILE="50${PN}-gentoo-1.54.el"
+
+pkg_postinst() {
+ elisp_pkg_postinst
+ optfeature "ebuild commands support" sys-apps/portage
+ optfeature "additional development tools" dev-util/pkgdev
+ optfeature "ebuild QA utilities" dev-util/pkgcheck
+ optfeature "generating HTML from GLEPs" dev-python/docutils-glep
+}