summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-01-09 22:03:06 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-01-09 22:16:08 +0100
commit768967d8a26abd6fff23338af3f5dd012f75eff7 (patch)
treebec39c7478aa6c6223669fc863100c149b00178e /app-emacs/compat
parentkde-plasma/libksysguard: Disable flaky sensortreemodeltest (diff)
downloadgentoo-768967d8a26abd6fff23338af3f5dd012f75eff7.tar.gz
gentoo-768967d8a26abd6fff23338af3f5dd012f75eff7.tar.bz2
gentoo-768967d8a26abd6fff23338af3f5dd012f75eff7.zip
app-emacs/compat: bump to 29.1.1.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/compat')
-rw-r--r--app-emacs/compat/Manifest1
-rw-r--r--app-emacs/compat/compat-29.1.1.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/app-emacs/compat/Manifest b/app-emacs/compat/Manifest
index 063aef223227..8e409ac6ef90 100644
--- a/app-emacs/compat/Manifest
+++ b/app-emacs/compat/Manifest
@@ -2,3 +2,4 @@ DIST compat-28.1.1.3.tar.gz 72597 BLAKE2B 82186713370fed7f97eb057cb330d77c1d7582
DIST compat-28.1.2.1.tar.gz 82434 BLAKE2B daf82d8f44af3f1b20dd25d042f401623d84f64a54c3b919714cd13fe4100d3b332e323a5fea5a643cdfc2dfe8b76a6a5684ad676fc595901df50a43e44b82f2 SHA512 7d2697b9b5bce25f44ab67438dd2b99bbd5072ed15193264cbd35473796d711d2b8f40db126478ea3c5de55609881ee20555e8a91d075df03f20610164f05d89
DIST compat-28.1.2.2.tar.gz 82479 BLAKE2B 154104a3d1cf953f712de357d21736d648289dbdaccb0f9ca5cbd44cb1e41b9b7b4b52394548658b47216f9205f28d2020b015d22b5d0c4df63c79794ddfc56e SHA512 65cafbf4d48815f447e412c4dbd87c5bd3357df5302660a5296582648926f8e3fe96b4b90b53674f18be8affe66af95c8db7e58d7a9dd63d2b57983962e5a53c
DIST compat-29.1.0.1.tar.gz 98171 BLAKE2B 46fd4052b7e3f6deb7789cb50d2d6c19d698531de04a171b3afc9035ed6ff3e204ee58e770eb699c05d722141b409e34dc13df1af6e3cda275ff107759a0a957 SHA512 51af7d1f87c838d421f017f2bdcce215e6951bd69181abff64c2c87f6ff1aac1b5f29e0dc91be2f48589e9a6092007a99d987791213801c7e0d89a372dfa4b72
+DIST compat-29.1.1.0.tar.gz 94072 BLAKE2B 675f0bbf4411fb0d2c2e8f77bcd62dbe56da1f052bd6e390dade0c8075eaa480bb387280a29ae09396a2f4bf27746ae1065d38dd1b7882b9c8c0ec3a4eb776e5 SHA512 5c7b093314cd8f8d8cbab4f470a64d3f104d0e79d2881f2f2309700c6fe5f58a72a8a65379868edba33c0b6af1d43f1474e2fefc65c033f39981d29fca35259a
diff --git a/app-emacs/compat/compat-29.1.1.0.ebuild b/app-emacs/compat/compat-29.1.1.0.ebuild
new file mode 100644
index 000000000000..459edf66eea1
--- /dev/null
+++ b/app-emacs/compat/compat-29.1.1.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=24.4
+
+inherit elisp
+
+DESCRIPTION="Compatibility libraries for Emacs"
+HOMEPAGE="https://github.com/emacs-compat/compat/
+ https://git.sr.ht/~pkal/compat/"
+SRC_URI="https://github.com/emacs-compat/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+BDEPEND="sys-apps/texinfo"
+
+ELISP_TEXINFO="${PN}.texi"
+
+src_compile() {
+ emake compile ${PN}.info
+}
+
+src_test() {
+ local has_json="$("${EMACS}" ${EMACSFLAGS} --eval "(princ (fboundp 'json-parse-string))")"
+ if [[ "${has_json}" != t ]] ; then
+ local line
+ while read line ; do
+ ewarn "${line}"
+ done <<-EOF
+ Your current Emacs version does not support native JSON parsing,
+ which is required for running tests of ${CATEGORY}/${PN}.
+ Emerge >=app-editors/emacs-27 with USE="json" and use "eselect emacs"
+ to select that version.
+ EOF
+ else
+ emake test
+ fi
+}