summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emacs/color-theme
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emacs/color-theme')
-rw-r--r--app-emacs/color-theme/Manifest1
-rw-r--r--app-emacs/color-theme/color-theme-6.6.0-r1.ebuild34
-rw-r--r--app-emacs/color-theme/files/50color-theme-gentoo.el109
-rw-r--r--app-emacs/color-theme/files/color-theme-6.6.0-replace-in-string.patch30
-rw-r--r--app-emacs/color-theme/metadata.xml5
5 files changed, 179 insertions, 0 deletions
diff --git a/app-emacs/color-theme/Manifest b/app-emacs/color-theme/Manifest
new file mode 100644
index 000000000000..bd5e4e8456fa
--- /dev/null
+++ b/app-emacs/color-theme/Manifest
@@ -0,0 +1 @@
+DIST color-theme-6.6.0.tar.gz 124858 SHA256 56d35f02dc4c8dd386a7242007432adc458466c8a48d0d680eda1826197ca17b SHA512 4faa22900f6ad4a1dd57452470e23b57827d3f02bf2b9e3c4eed6f5693432d6478aa5008e67f219a95412a63fe52dbcad15b0ac7a3b4d39f1d28ceda75e5e76c WHIRLPOOL d4139af0f1c2d3c14e6b142cb7eac1f28bcb89cf011e4b6041fca0bc5c01810ddb2e1e9cc916887c5f11741fe69d0fed996473d5f662ec35a85de224909b96ae
diff --git a/app-emacs/color-theme/color-theme-6.6.0-r1.ebuild b/app-emacs/color-theme/color-theme-6.6.0-r1.ebuild
new file mode 100644
index 000000000000..e361ac977bb4
--- /dev/null
+++ b/app-emacs/color-theme/color-theme-6.6.0-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit readme.gentoo elisp
+
+DESCRIPTION="Install color themes (includes many themes and allows you to share your own with the world)"
+HOMEPAGE="http://www.nongnu.org/color-theme/"
+SRC_URI="http://download.savannah.gnu.org/releases-noredirect/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 ppc sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-macos"
+
+ELISP_PATCHES="${P}-replace-in-string.patch"
+ELISP_REMOVE="color-theme-autoloads.*"
+SITEFILE="50${PN}-gentoo.el"
+
+src_install() {
+ elisp-install ${PN} *.el *.elc
+ elisp-install ${PN}/themes themes/*.el
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ dodoc AUTHORS BUGS ChangeLog README
+
+ DOC_CONTENTS="To use color-theme non-interactively, initialise it
+ in your ~/.emacs file as in the following example (which is
+ for the \"Blue Sea\" theme):
+ \n
+ \n(color-theme-initialize)
+ \n(color-theme-blue-sea)"
+ readme.gentoo_create_doc
+}
diff --git a/app-emacs/color-theme/files/50color-theme-gentoo.el b/app-emacs/color-theme/files/50color-theme-gentoo.el
new file mode 100644
index 000000000000..9d43c350fffd
--- /dev/null
+++ b/app-emacs/color-theme/files/50color-theme-gentoo.el
@@ -0,0 +1,109 @@
+(add-to-list 'load-path "@SITELISP@")
+
+(autoload (quote color-theme-select) "color-theme" "\
+Displays a special buffer for selecting and installing a color theme.
+With optional prefix ARG, this buffer will include color theme libraries
+as well. A color theme library is in itself not complete, it must be
+used as part of another color theme to be useful. Thus, color theme
+libraries are mainly useful for color theme authors." t nil)
+
+(autoload (quote color-theme-describe) "color-theme" "\
+Describe color theme listed at point.
+This shows the documentation of the value of text-property color-theme
+at point. The text-property color-theme should be a color theme
+function. See `color-themes'." t nil)
+
+(autoload (quote color-theme-install-at-mouse) "color-theme" "\
+Install color theme clicked upon using the mouse.
+First argument EVENT is used to set point. Then
+`color-theme-install-at-point' is called." t nil)
+
+(autoload (quote color-theme-install-at-point-for-current-frame) "color-theme" "\
+Install color theme at point for current frame only.
+Binds `color-theme-is-global' to nil and calls
+`color-theme-install-at-point'." t nil)
+
+(autoload (quote color-theme-print) "color-theme" "\
+Print the current color theme function.
+
+You can contribute this function to <URL:news:gnu.emacs.sources> or
+paste it into your .emacs file and call it. That should recreate all
+the settings necessary for your color theme.
+
+Example:
+
+ (require 'color-theme)
+ (defun my-color-theme ()
+ \"Color theme by Alex Schroeder, created 2000-05-17.\"
+ (interactive)
+ (color-theme-install
+ '(...
+ ...
+ ...)))
+ (my-color-theme)
+
+If you want to use a specific color theme function, you can call the
+color theme function in your .emacs directly.
+
+Example:
+
+ (require 'color-theme)
+ (color-theme-gnome2)" t nil)
+
+(autoload (quote color-theme-analyze-defun) "color-theme" "\
+Once you have a color-theme printed, check for missing faces.
+This is used by maintainers who receive a color-theme submission
+and want to make sure it follows the guidelines by the color-theme
+author." t nil)
+
+(autoload (quote color-theme-make-snapshot) "color-theme" "\
+Return the definition of the current color-theme.
+The function returned will recreate the color-theme in use at the moment." nil nil)
+
+(autoload (quote color-theme-compare) "color-theme" "\
+Compare two color themes.
+This will print the differences between installing THEME-A and
+installing THEME-B. Note that the order is important: If a face is
+defined in THEME-A and not in THEME-B, then this will not show up as a
+difference, because there is no reset before installing THEME-B. If a
+face is defined in THEME-B and not in THEME-A, then this will show up as
+a difference." t nil)
+
+(autoload (quote color-theme-install) "color-theme" "\
+Install a color theme defined by frame parameters, variables and faces.
+
+The theme is installed for all present and future frames; any missing
+faces are created. See `color-theme-install-faces'.
+
+THEME is a color theme definition. See below for more information.
+
+If you want to install a color theme from your .emacs, use the output
+generated by `color-theme-print'. This produces color theme function
+which you can copy to your .emacs.
+
+A color theme definition is a list:
+\([FUNCTION] FRAME-PARAMETERS VARIABLE-SETTINGS FACE-DEFINITIONS)
+
+FUNCTION is the color theme function which called `color-theme-install'.
+This is no longer used. There was a time when this package supported
+automatic factoring of color themes. This has been abandoned.
+
+FRAME-PARAMETERS is an alist of frame parameters. These are installed
+with `color-theme-install-frame-params'. These are installed last such
+that any changes to the default face can be changed by the frame
+parameters.
+
+VARIABLE-DEFINITIONS is an alist of variable settings. These are
+installed with `color-theme-install-variables'.
+
+FACE-DEFINITIONS is an alist of face definitions. These are installed
+with `color-theme-install-faces'.
+
+If `color-theme-is-cumulative' is nil, a color theme will undo face and
+frame-parameter settings of previous color themes." nil nil)
+
+(autoload (quote color-theme-submit) "color-theme" "\
+Submit your color-theme to the maintainer." t nil)
+
+(autoload (quote color-theme-initialize) "color-theme" "\
+Initialize the color theme package by loading color-theme-libraries." t nil)
diff --git a/app-emacs/color-theme/files/color-theme-6.6.0-replace-in-string.patch b/app-emacs/color-theme/files/color-theme-6.6.0-replace-in-string.patch
new file mode 100644
index 000000000000..bfd6bedd8983
--- /dev/null
+++ b/app-emacs/color-theme/files/color-theme-6.6.0-replace-in-string.patch
@@ -0,0 +1,30 @@
+http://bugs.gentoo.org/280293
+
+--- color-theme-6.6.0-orig/color-theme.el 2006-05-28 15:07:29.000000000 +0200
++++ color-theme-6.6.0/color-theme.el 2009-08-10 10:17:00.000000000 +0200
+@@ -72,11 +72,6 @@
+ (string-match "XEmacs" emacs-version))
+ "Non-nil if running XEmacs.")
+
+-;; Add this since it appears to miss in emacs-2x
+-(or (fboundp 'replace-in-string)
+- (defun replace-in-string (target old new)
+- (replace-regexp-in-string old new target)))
+-
+ ;; face-attr-construct has a problem in Emacs 20.7 and older when
+ ;; dealing with inverse-video faces. Here is a short test to check
+ ;; wether you are affected.
+@@ -1626,9 +1621,10 @@
+ (add-to-list 'color-themes
+ (list ',n
+ (upcase-initials
+- (replace-in-string
+- (replace-in-string
+- (symbol-name ',n) "^color-theme-" "") "-" " "))
++ (replace-regexp-in-string
++ "-" " "
++ (replace-regexp-in-string
++ "^color-theme-" "" (symbol-name ',n))))
+ ,author))
+ (defun ,n ()
+ ,description
diff --git a/app-emacs/color-theme/metadata.xml b/app-emacs/color-theme/metadata.xml
new file mode 100644
index 000000000000..bc306fe58224
--- /dev/null
+++ b/app-emacs/color-theme/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+</pkgmetadata>