summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-09-03 16:41:42 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-09-03 20:44:27 +0200
commita0e6196feb85403bcbc9bebbb37b840aeaebb978 (patch)
tree5f49bcf7b6d5eab7d4aeae563d877f9405c46b97 /app-emacs/async
parentapp-emacs/helm: drop old 3.9.8 (diff)
downloadgentoo-a0e6196feb85403bcbc9bebbb37b840aeaebb978.tar.gz
gentoo-a0e6196feb85403bcbc9bebbb37b840aeaebb978.tar.bz2
gentoo-a0e6196feb85403bcbc9bebbb37b840aeaebb978.zip
app-emacs/async: bump to 1.9.9
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/async')
-rw-r--r--app-emacs/async/Manifest1
-rw-r--r--app-emacs/async/async-1.9.9.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/app-emacs/async/Manifest b/app-emacs/async/Manifest
index 5c875af3bfcf..5d16310c1957 100644
--- a/app-emacs/async/Manifest
+++ b/app-emacs/async/Manifest
@@ -1 +1,2 @@
DIST emacs-async-1.9.8.tar.gz 33508 BLAKE2B 2e22c67c5bebe3c821d010a0f379aab9728fedb7a6345b81bcb7b093ffc54dbba1c7fa79d41eb5878b24024056607fff7d532b4702a7dc52163837af93c83f41 SHA512 c4c5406ce28dbfea0130b43a7f85d0a47626cf630c73318280896bd28f29bf5a8949077c242cd9c6162fecabbc619b2a270d532df341c4e286f1f7bb499da5f3
+DIST emacs-async-1.9.9.tar.gz 35182 BLAKE2B 80e981289d768d9c69922c7c439ba7bcfe5d803ebf211ebc64d7428b88d3a7a90e9f824a5bb06d21aa90cfe998ce1915be32a9ddd28eafe177162b104f67081a SHA512 ddf4e6bdc3a305f987396a34d80cc957040bc726106ac0f28bb288ce5eb77d4e35d78214834757c90a7bf85f896a5d095493673117ef2a0eeacf3e366ee64714
diff --git a/app-emacs/async/async-1.9.9.ebuild b/app-emacs/async/async-1.9.9.ebuild
new file mode 100644
index 000000000000..842a0084c79e
--- /dev/null
+++ b/app-emacs/async/async-1.9.9.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+[[ "${PV}" == 1.9.9 ]] && COMMIT="f317b0c9c3e60a959f45d035ed5e31a78f1263ac"
+
+REAL_PN="emacs-async"
+REAL_P="${REAL_PN}-${PV}"
+
+inherit elisp
+
+DESCRIPTION="Simple library for asynchronous processing in Emacs"
+HOMEPAGE="https://github.com/jwiegley/emacs-async/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/jwiegley/${REAL_PN}.git"
+else
+ SRC_URI="https://github.com/jwiegley/${REAL_PN}/archive/${COMMIT}.tar.gz
+ -> ${REAL_P}.tar.gz"
+ S="${WORKDIR}/${REAL_PN}-${COMMIT}"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+elisp-enable-tests buttercup
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}