summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-11-27 19:36:39 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-11-27 19:59:45 +0100
commit1aed32d91feb2308f048799b41c8a754d64f3694 (patch)
treedf76514dc0c8dd5c897717bfe7d11cbd1425cf99 /app-emacs/async
parentapp-containers/skopeo: style fix (diff)
downloadgentoo-1aed32d91feb2308f048799b41c8a754d64f3694.tar.gz
gentoo-1aed32d91feb2308f048799b41c8a754d64f3694.tar.bz2
gentoo-1aed32d91feb2308f048799b41c8a754d64f3694.zip
app-emacs/async: bump to 1.9.8
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/async')
-rw-r--r--app-emacs/async/Manifest1
-rw-r--r--app-emacs/async/async-1.9.8.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/app-emacs/async/Manifest b/app-emacs/async/Manifest
index 62ae29f1a332..28b468b62889 100644
--- a/app-emacs/async/Manifest
+++ b/app-emacs/async/Manifest
@@ -1 +1,2 @@
DIST emacs-async-1.9.7.tar.gz 28411 BLAKE2B a033b0d84a61f133c0a871b6355626a67250b61c6ae4640331c8d14b3abda0d9d7405bb9fb09128874053cc310b3532772f8a515afb63b6d740492e10c9af5a9 SHA512 ca2c118594cc1478b1f68b3fce7e2b9c10cc3a90146b33a2631286cdef60c39932aa0036837ea9546f963105de7fae8fbe3ab8b6f36daff95323ca89a0fea645
+DIST emacs-async-1.9.8.tar.gz 33508 BLAKE2B 2e22c67c5bebe3c821d010a0f379aab9728fedb7a6345b81bcb7b093ffc54dbba1c7fa79d41eb5878b24024056607fff7d532b4702a7dc52163837af93c83f41 SHA512 c4c5406ce28dbfea0130b43a7f85d0a47626cf630c73318280896bd28f29bf5a8949077c242cd9c6162fecabbc619b2a270d532df341c4e286f1f7bb499da5f3
diff --git a/app-emacs/async/async-1.9.8.ebuild b/app-emacs/async/async-1.9.8.ebuild
new file mode 100644
index 000000000000..bdc3e15862b2
--- /dev/null
+++ b/app-emacs/async/async-1.9.8.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+MY_P="emacs-async-${PV}"
+DESCRIPTION="Simple library for asynchronous processing in Emacs"
+HOMEPAGE="https://github.com/jwiegley/emacs-async"
+SRC_URI="https://github.com/jwiegley/emacs-async/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+SITEFILE="50${PN}-gentoo.el"
+DOCS="README.md"
+
+src_compile() {
+ elisp-compile *.el
+ elisp-make-autoload-file
+}