summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-09-15 12:14:49 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2023-09-19 20:48:09 +0300
commitdd8361039bdfedb6809f815b5dcdcd2f27edbc1b (patch)
tree96a4c62a059465000c2cd7b27dcc3962a9b8fd93 /app-editors
parentdev-lang/go-bootstrap: add arm64-macos keyword (diff)
downloadgentoo-dd8361039bdfedb6809f815b5dcdcd2f27edbc1b.tar.gz
gentoo-dd8361039bdfedb6809f815b5dcdcd2f27edbc1b.tar.bz2
gentoo-dd8361039bdfedb6809f815b5dcdcd2f27edbc1b.zip
app-editors/neovim: fix VariableShadowed
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/neovim/neovim-0.9.0-r1.ebuild3
-rw-r--r--app-editors/neovim/neovim-0.9.1.ebuild3
-rw-r--r--app-editors/neovim/neovim-0.9.2.ebuild3
-rw-r--r--app-editors/neovim/neovim-9999.ebuild3
4 files changed, 4 insertions, 8 deletions
diff --git a/app-editors/neovim/neovim-0.9.0-r1.ebuild b/app-editors/neovim/neovim-0.9.0-r1.ebuild
index 71f6158101f0..3e6d89c050a4 100644
--- a/app-editors/neovim/neovim-0.9.0-r1.ebuild
+++ b/app-editors/neovim/neovim-0.9.0-r1.ebuild
@@ -23,10 +23,9 @@ LICENSE="Apache-2.0 vim"
SLOT="0"
IUSE="+lto +nvimpager test"
-REQUIRED_USE="${LUA_REQUIRED_USE}"
# Upstream say the test library needs LuaJIT
# https://github.com/neovim/neovim/blob/91109ffda23d0ce61cec245b1f4ffb99e7591b62/CMakeLists.txt#L377
-REQUIRED_USE="test? ( lua_single_target_luajit )"
+REQUIRED_USE="${LUA_REQUIRED_USE} test? ( lua_single_target_luajit )"
# TODO: Get tests running
RESTRICT="!test? ( test ) test"
diff --git a/app-editors/neovim/neovim-0.9.1.ebuild b/app-editors/neovim/neovim-0.9.1.ebuild
index 4e162285188c..f144c140c69f 100644
--- a/app-editors/neovim/neovim-0.9.1.ebuild
+++ b/app-editors/neovim/neovim-0.9.1.ebuild
@@ -23,10 +23,9 @@ LICENSE="Apache-2.0 vim"
SLOT="0"
IUSE="+lto +nvimpager test"
-REQUIRED_USE="${LUA_REQUIRED_USE}"
# Upstream say the test library needs LuaJIT
# https://github.com/neovim/neovim/blob/91109ffda23d0ce61cec245b1f4ffb99e7591b62/CMakeLists.txt#L377
-REQUIRED_USE="test? ( lua_single_target_luajit )"
+REQUIRED_USE="${LUA_REQUIRED_USE} test? ( lua_single_target_luajit )"
# TODO: Get tests running
RESTRICT="!test? ( test ) test"
diff --git a/app-editors/neovim/neovim-0.9.2.ebuild b/app-editors/neovim/neovim-0.9.2.ebuild
index 5a5a4f0cada7..ec45d50f6dd1 100644
--- a/app-editors/neovim/neovim-0.9.2.ebuild
+++ b/app-editors/neovim/neovim-0.9.2.ebuild
@@ -23,10 +23,9 @@ LICENSE="Apache-2.0 vim"
SLOT="0"
IUSE="+lto +nvimpager test"
-REQUIRED_USE="${LUA_REQUIRED_USE}"
# Upstream say the test library needs LuaJIT
# https://github.com/neovim/neovim/blob/91109ffda23d0ce61cec245b1f4ffb99e7591b62/CMakeLists.txt#L377
-REQUIRED_USE="test? ( lua_single_target_luajit )"
+REQUIRED_USE="${LUA_REQUIRED_USE} test? ( lua_single_target_luajit )"
# TODO: Get tests running
RESTRICT="!test? ( test ) test"
diff --git a/app-editors/neovim/neovim-9999.ebuild b/app-editors/neovim/neovim-9999.ebuild
index f341eed583f4..6c5ebb7aaf30 100644
--- a/app-editors/neovim/neovim-9999.ebuild
+++ b/app-editors/neovim/neovim-9999.ebuild
@@ -23,10 +23,9 @@ LICENSE="Apache-2.0 vim"
SLOT="0"
IUSE="+lto +nvimpager test"
-REQUIRED_USE="${LUA_REQUIRED_USE}"
# Upstream say the test library needs LuaJIT
# https://github.com/neovim/neovim/blob/91109ffda23d0ce61cec245b1f4ffb99e7591b62/CMakeLists.txt#L377
-REQUIRED_USE="test? ( lua_single_target_luajit )"
+REQUIRED_USE="${LUA_REQUIRED_USE} test? ( lua_single_target_luajit )"
# TODO: Get tests running
RESTRICT="!test? ( test ) test"