summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2024-06-08 12:09:45 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2024-06-08 15:02:23 +0300
commit55397f68967ec1c18586da8353cab3a390719e7e (patch)
treef3bef269a98dde0c7a17674684744f490f04db3c /app-editors
parentnet-dns/idnkit: drop 2.3 (diff)
downloadgentoo-55397f68967ec1c18586da8353cab3a390719e7e.tar.gz
gentoo-55397f68967ec1c18586da8353cab3a390719e7e.tar.bz2
gentoo-55397f68967ec1c18586da8353cab3a390719e7e.zip
app-editors/moe: add 1.14
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/moe/Manifest1
-rw-r--r--app-editors/moe/files/moe-1.14-respect-user-flags.patch17
-rw-r--r--app-editors/moe/moe-1.14.ebuild27
3 files changed, 45 insertions, 0 deletions
diff --git a/app-editors/moe/Manifest b/app-editors/moe/Manifest
index d14cfd3430ca..201bd1d7c0fa 100644
--- a/app-editors/moe/Manifest
+++ b/app-editors/moe/Manifest
@@ -1 +1,2 @@
DIST moe-1.12.tar.lz 87917 BLAKE2B b036b24193045cd5c64812af13e6cf542700e649e78f3ba416501d0915c0ac2eef09bebdb333d145e0428dfacdccef431588ce93b1f407a41a7bd7e0acbc163c SHA512 f0d5daba70d0018ce82d6673749b8f688c0bac58de7684cc24f5badffd6868d425c9f771404186ab5cec12ab94c3e20af870bd920bfef0432a622925838ebed7
+DIST moe-1.14.tar.lz 92905 BLAKE2B c4adb3ca00f48c6a36547da063aa1ce9327823fed26eb9e0ac25d837b5df207988c2259156bb841727463b74de450d2cb0475746a0e19d926aeb65ac38079561 SHA512 db45f7c05b9a1a06085b2604eb8e9857caeb7d3a56a4815df208806bbbf19cc47b19776619635c70860142cb8bb775c0eaf31b9b07698cc83b74f1c6d6f47d5c
diff --git a/app-editors/moe/files/moe-1.14-respect-user-flags.patch b/app-editors/moe/files/moe-1.14-respect-user-flags.patch
new file mode 100644
index 000000000000..8616c8095962
--- /dev/null
+++ b/app-editors/moe/files/moe-1.14-respect-user-flags.patch
@@ -0,0 +1,17 @@
+--- a/configure
++++ b/configure
+@@ -21,11 +21,9 @@
+ infodir='$(datarootdir)/info'
+ mandir='$(datarootdir)/man'
+ sysconfdir='$(prefix)/etc'
+-CXX=g++
+-CPPFLAGS=
+-CXXFLAGS='-Wall -W -O2'
+-LDFLAGS=
+-LIBS=-lncurses
++CPPFLAGS="$(${PKG_CONFIG} --cflags ncurses) ${CPPFLAGS}"
++CXXFLAGS="-Wall -W ${CXXFLAGS}"
++LIBS="$(${PKG_CONFIG} --libs ncurses) ${LIBS}"
+ MAKEINFO=makeinfo
+
+ # checking whether we are using GNU C++.
diff --git a/app-editors/moe/moe-1.14.ebuild b/app-editors/moe/moe-1.14.ebuild
new file mode 100644
index 000000000000..90da6b924e76
--- /dev/null
+++ b/app-editors/moe/moe-1.14.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs unpacker
+
+DESCRIPTION="Powerful and user-friendly console text editor"
+HOMEPAGE="https://www.gnu.org/software/moe/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.lz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="sys-libs/ncurses:="
+DEPEND="${RDEPEND}"
+BDEPEND="
+ $(unpacker_src_uri_depends)
+ virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${P}-respect-user-flags.patch )
+
+src_configure() {
+ tc-export CXX PKG_CONFIG
+ default
+}